PureData 0.49 update

Yeah, i can’t work on patches anymore :frowning: Please fix!

After trying both right click ‘Pd’ options in the desktop gui, i can now no longer open patches at all when using TigerVNC - even when they are selected using the scroll wheel and menu on the organelle. Patches open as normal when rebooting the organelle and not using tigerVNC.

@JEREMYWY point is different - its going to the desktop link… nothing more ominous than that.

as far as i know, no one (except you now) has reported any issues with running or editing using pd49.

Ive got this running on 2 different organelles both using VNC and not, editing patches fine… and have been for a long time :wink: (i would not have released if there were issues !)

the fact that it works without vnc, also indicates there is no issue with PD49,
as pure data doesn’t know/care if its writing to a real display or virtual display.

so really its something to do with VNC not PD.

can you give me precise description of what happens?
e.g. does the patch start? (ie. do you see it on the Organelle),
if so that sounds like its not starting in ‘gui’ mode,

also , have you tried restarting mother? I think its the smiley face icon?
you can also open up the terminal, and type

ps auxwww

and look for the PD process after you have started the app, what command line options does it have?

also did you change screen resolutions? perhaps look at that
(I also did, but you need to start somewhere to see what the issue is)

perhaps try reinstalling VNC, though this seems its unlikely to do anything, but perhaps something odd has happened?

Unfortunately, I think I’m hitting the same issue. I can’t launch any patches after starting tigerVNC (organelle screen is just black), even if WIFI isn’t connected, until I restart the organelle.
I captured a log and the output in the included zip file, as well as a the output of ps auxwww
I also tried SSHing in and launching a patch and that worked, I’ve included a log of that as well as well.

I think pd is just hanging when launching without -nogui, I tried launching it manually in tigerVNC and I don’t get any output even with -verbose on though the pd process is running. I can manually launch with the -nogui flag and it looks ok.
logs.zip (5.6 KB)

ok, the issue is the first time PD is starting its trying to write to a file… and failing to get a write lock since the filesystem is readonly.

do the following in a terminal window

~/scripts/remount-rw.sh

run PD/ patch whatever, say no to dialog , exit pd

~/scripts/remount-ro.sh

its only the first time, once its done - it won’t do it again.

unfortunately, I don’t have time to find out what file its writing to prevent this (its not .pdsettings) at the moment. once i know which file it is I can add it to the install to stop it doing it.
(my guess is its some new file its storing library paths in… that’s new, and so creates it on first use when using gui )

as noted, normal running of patches is unaffected its only when you bring up the gui.
and its not related to VNC either, it does it with X and an hdmi monitor.

1 Like

Will it allow you to edit patches with a monitor? Or is this just happening through VNC? I have some patches I planned to edit today. But obviously if it’s messing with people’s organelles I want to try and avoid it.

Ive just given the solution.

So far people have only mentioned vnc. I was asking them if it happened when connected to hdmi monitor.

I said it was not only vnc

Thank you for the quick fix! Working well now.
Not sure if it the culprit but it looks like the file:
/root/.config/Pd/org.puredata.pd.pd-gui/docspath.conf
was created after opening.

1 Like

Trying to enter

at terminal had this effect for me:

Smiley face refreshes organelle screen but has no effect on the problem. Unable to open patches in any way while using gui, clicking on pd files in gui does nothing and using scrollwheel and menu on organelle yields a black screen. @WyrdAl clearly suceeded with your advice @thetechnobear , have i entered the command incorrectly at the terminal?

Sorry my mistake it’s remount-rw.sh, I’ve corrected above post.

the scripts are really inconsistent between - and _ , so ii use command completion (tab) :slight_smile:

@WyrdAl , cool that’s probably it!
When I get a chance I’ll see if it I create from the installer it fixes the issue.
(pretty sure it will)

2 Likes

Okay great, the rw/ro commands fixed the issue of not being able to open patches by using the organelle encoder and menu system while using VNC/gui mode.

However, I remain unable to open pd files by double clicking on the files from within the gui/file browser. I double click and nothing happens. The organelle shows two different pd programs with which to open the files when i right click, but selecting either has no effect. Still need some help with this. :confused:

@Wannop - copy n paste the following one line at at time to fix your issue.

~/scripts/remount-rw.sh
rm /usr/lib/pd/bin/pd
ln  -s /usr/bin/pd  /usr/lib/pd/bin/pd
 ~/scripts/remount-ro.sh

there still will be two entries, either will work.

there were two entires before, these were not installed by PD49, as ive checked the package list , and also the date/times confirm they were from the original install.
(I don’t have the time to clean up these now)

Ive fixed this and the previous issue and uploaded to patchstorage.com

2 Likes

Fantastic, can’t wait to get stuck in. Cheers.

I installed the zip file but my organelle can’t unzip the file. What should I do?

What’s the error in the Organelle?

Given it’s worked for so many others , I’d say it’s likely your usb drive is faulty - try another one.

Hi everyone!
I have just bought the new OrganelleM and I was trying to install pd49, but when installing, the organelle shows an error: “only valid for organelle-1. Install failed. deploy failed”. Did I miss something in the forum?

Thanks everyone!

It’s not required for organelle-m as it already has 0.49 installed :slight_smile:

( is expect when OS 3.2 is out for organelle-1, that will also have pd49)

2 Likes