PureData 0.49 update

Bold move, to release such an important patch on April the first. :slight_smile: I will install it tonight.

3 Likes

only fools day in the morning, I posted after midday :slight_smile:

And if you download and install in the evening… all good!! its for real!
No fooling around;

Once again thanks for pushing forward :wink:

1 Like

I upgraded PD on the organelle, and everything went absolutely smooth, no problems during install no compatibilty issues detected so far. Thanks again for the update! Works like a charm.

2 Likes

btw: if you get a message from patchstorage its been update, it hasn’t really…
Ive just changed it to being a ‘zop file’ as PatchStorage have fixed the issue on their end which prevented .zop extensions - so its the same thing :slight_smile:

2 Likes

Thank you for this!
One question: first time running a patch using TigerVNC (thank you a lot for this too!), and this pops up:
image
In the organelle, I’m kinda dizzy about what I should choose…

2 Likes

choose no :slight_smile:

it doesn’t actually make any difference , and will fail anyway (root filesystem is read-only)…

thanks for the feedback though, I’ll see, if i can find a way to stop it popping up.

You are welcome. But probably was nothing, because I closed the patch without selecting Yes, No, or Cancel and the second time I opened one to follow your advice and choose “No”, the pop up was no more! So, it’s super corner case, only you can see it in the first patch you run after the update.

1 Like

Working great! the only thing I’ve noticed and might not be an issue for everyone is I can’t open .pd files in the navigator gui on the organelle. when i right click and do ‘open with’ there are 2 pd icons, which might be a hint.

Thanks :slight_smile:

1 Like

Yeah, i can’t work on patches anymore :frowning: Please fix!

After trying both right click ‘Pd’ options in the desktop gui, i can now no longer open patches at all when using TigerVNC - even when they are selected using the scroll wheel and menu on the organelle. Patches open as normal when rebooting the organelle and not using tigerVNC.

@JEREMYWY point is different - its going to the desktop link… nothing more ominous than that.

as far as i know, no one (except you now) has reported any issues with running or editing using pd49.

Ive got this running on 2 different organelles both using VNC and not, editing patches fine… and have been for a long time :wink: (i would not have released if there were issues !)

the fact that it works without vnc, also indicates there is no issue with PD49,
as pure data doesn’t know/care if its writing to a real display or virtual display.

so really its something to do with VNC not PD.

can you give me precise description of what happens?
e.g. does the patch start? (ie. do you see it on the Organelle),
if so that sounds like its not starting in ‘gui’ mode,

also , have you tried restarting mother? I think its the smiley face icon?
you can also open up the terminal, and type

ps auxwww

and look for the PD process after you have started the app, what command line options does it have?

also did you change screen resolutions? perhaps look at that
(I also did, but you need to start somewhere to see what the issue is)

perhaps try reinstalling VNC, though this seems its unlikely to do anything, but perhaps something odd has happened?

Unfortunately, I think I’m hitting the same issue. I can’t launch any patches after starting tigerVNC (organelle screen is just black), even if WIFI isn’t connected, until I restart the organelle.
I captured a log and the output in the included zip file, as well as a the output of ps auxwww
I also tried SSHing in and launching a patch and that worked, I’ve included a log of that as well as well.

I think pd is just hanging when launching without -nogui, I tried launching it manually in tigerVNC and I don’t get any output even with -verbose on though the pd process is running. I can manually launch with the -nogui flag and it looks ok.
logs.zip (5.6 KB)

ok, the issue is the first time PD is starting its trying to write to a file… and failing to get a write lock since the filesystem is readonly.

do the following in a terminal window

~/scripts/remount-rw.sh

run PD/ patch whatever, say no to dialog , exit pd

~/scripts/remount-ro.sh

its only the first time, once its done - it won’t do it again.

unfortunately, I don’t have time to find out what file its writing to prevent this (its not .pdsettings) at the moment. once i know which file it is I can add it to the install to stop it doing it.
(my guess is its some new file its storing library paths in… that’s new, and so creates it on first use when using gui )

as noted, normal running of patches is unaffected its only when you bring up the gui.
and its not related to VNC either, it does it with X and an hdmi monitor.

1 Like

Will it allow you to edit patches with a monitor? Or is this just happening through VNC? I have some patches I planned to edit today. But obviously if it’s messing with people’s organelles I want to try and avoid it.

Ive just given the solution.

So far people have only mentioned vnc. I was asking them if it happened when connected to hdmi monitor.

I said it was not only vnc

Thank you for the quick fix! Working well now.
Not sure if it the culprit but it looks like the file:
/root/.config/Pd/org.puredata.pd.pd-gui/docspath.conf
was created after opening.

1 Like

Trying to enter

at terminal had this effect for me: