Read-Only Filesystem

Hey guys

Can’t seem to save any changes to patches while editing/creating them (monitor, keyboard and mouse style) on my Organelle. Every time I try, the dialog box tells me the patch is Read-Only. I thought this rule was just for SD card? Strange as I was happily editing last week. Very irritating too as I only realised this after about 45 minutes of editing.

Please assist :slight_smile:

I’m on OS 2.2 B15
Using a powered USB hub with USB stick, keyboard and mouse attached
Midi Interface plugged into spare USB slot on organelle.

Tried accessing patches both via organelle interface and with ‘usb disk’ icon on organelles desktop with a mouse. Tried with a variety of patches.


are you using ‘save as’ in PD? if so are you sure you have selected the /usbdrive and patches directory. (pure data doesn’t track the current directory very well - ok, its rubbish at it, and tends to default back to home directory, which is read only, as its on the sdcard )

I’ll go have a check on my organelle… but Ive been messing about with patches recently, and didn’t notice any issue…

I have! Very confused :frowning:

All good here…
OS 2.2 TBb15, either “Save New” from OG or HDMI+Keyboard+mouse style.

Must be trying to access read only areas.

1 Like

just checked on my Organelle with latest beta on it and its fine here too…

what i would try is:

  • use ‘save as’ in PD, and explicitly try to save as a new directory on the usb drive
  • check the usb stick can be written to on a PC etc
  • try another usb stick if you have one…

im wondering perhaps some how the stick is corrupted, and so Organelle cannot write to it due to that.

1 Like

tried writing the same file to other locations and it worked just fine.
tried overwriting main.pd in patch directory again
nothing to see here folks…

thanks for the support - probably human error

i have been experiencing trouble with my power adapter recently - some cutouts, so - that could have corrupted some files and created an issue perhaps.

as an additional query - does anybody else have trouble with the ‘undo’ function when patching directly on organelle?

I’m fairly new to all this (Pd-Organelle) but undo is ok; one level only…

For me it always says 'no no no, you should try ‘file_menu_undo’ or some crap like that, when that’s exactly what I’ve just done.


Mine did this too last night. I had to eject and reload the sd-card a few times and then it worked again. Did you try this?

No I try to avoid removing the SD card, maybe that’s over cautious. I’ll give it a go. Cheers man.

to help the undo issue? or the read-only issue?
whilst the organelle was powered off?

I very much doubt this is the reason it started working, little technical basis… if you kept rebooting the organelle in between, this is much more likely to have been the thing that ‘fixed’ it.

if these kind of issues occur, id highly recommend you run DiagnosticLog, this captures a few system messages, so this may give us the opportunity to try to understand the underlying cause.

(id say the same of all issues, I think the current issues being blamed on usb stick failure are also possibly not being correctly diagnosed)

also one thing that potentially could be causing issues (usb stick and sdcard) is if the Organelle is not being shutdown correctly. this is really important!
(Ive also noticed the organelle, is not doing a full clean shutdown anyway, which also could be part of the problem)

@Wannop Argh yes SORRY I mean USB thumb drive… Argh, on Axoloti it is Sd-card- Sorry for the confusion.