Remote Patching (using VNC)


#22

I just got a new 32GB Sandisk MicroSDHC - followed instructions on this TOTALLY ACE forum to install OS 3.1- resized it with the new resizeSD patch - connected to Wifi - uploaded the TigerVNC.zop - installed and everything works perfectly.

It’s a great idea to get a new larger SD card and go through this process - I really didn’t enjoy patching and transferring USB back and forth and I didn’t want to use a HDMI connection with a monitor / extra peripherals either… These solutions are excellent so once again a very massive thank you to @thetechnobear for all the hard work!

@Korb I am pretty sure you could get this working if you were to reflash your SD card - I am not sure it’s totally necessary to get a new one but you’ll need to follow instructions to do that here if you’re up for it >

look for ‘Installing the C&G OS 3.1 SD card image’

If you upload the TigerVNC.zop to your SD card over wifi using Patch Manager (organelle.local) I am confident you’ll get it working!


#23

@jasl @Edouard @Korb

hmm given a new 3.1 image fixed for @Edouard and @jasl , Im guess something in the 3.1 upgrade is ‘missing’ compared to the fresh image… (or a different version of something )

do each of you know (prior to the fresh 3.1 image) what you ‘upgrade’ path had been?
was it 1.0->2.1->2.2->3.0->3.1 or something different.

perhaps if we have a common pattern as to how a user upgraded, then perhaps its reproducible, and something can be taken into account…
the issue at the moment, is cannot reproduce the issue - so im a bit in the dark about how to fix.

anyway, the workaround of a fresh install is a good one - because as @jasl has noticed, if you have wifi and an sdcard , I think the Organelle experience is much nicer … none of that messing with usb sticks :slight_smile:
(also the sdcard is more reliable that many usb sticks)

the only drawback, is it means the user has to have a sdcard reader for the desktop, to install the fresh image - and whilst they are cheap, its not something everyone has.


#24

After a fresh installation everything works fine. @thetechnobear, thank you so much for this awseome feature.
In difference to the first installation, I use only the SD - Card. While my first trials, I run TigerVNC from then USB-Stick.I don’t know if this matters.
One observation I made, my Organelle crashed if I use the WebServer and TigerVNC in parallel.
Everything else is looking good so far.

Thanks !!!


#25

Hi,
Sadly I can’t manage to connect either.

v3.1 (running on the SD card)
Installed Tiger VNC.
WiFi running, Tiger VNC running. Unable to access from Safari (with the names, and IP)…


#26

2 questions:

a) did you do the install from the USB stick, or from the sdcard?
if you did it from the usb stick, can you try from the sdcard (so remove the usbstick, install , then also run from the sdcard)
b) did you upgrade to 3.1?

Id like to eliminate from possibilities this is not just an issue with running/installing from the usbstick

if its not this, then as Ive stated above, it appears to be something to do with the ‘fresh’ 3.1 OS image being different from an upgraded Organelle… which unfortunately at the moment I don’t have available.
(and frankly, it would take me an hour or so of faffing about to get to a state where I can even test this :frowning: )

another possibility, is if someone can take an image of their sd card and put it up online somewhere, then I could test that.
OR
the other possibility is if someone gets this and is familiar with linux, then they can :

  • look at my run script, and see if the link to the tmp drive is failing?
  • check the .vnc config is correct
  • get me a list of all pacman packages installed, which I can then compare against my fresh 3.1 install

unfortunately for now, if its not the usb stick vs sdcard , then the only workaround is doing the fresh OS 3.1 install, which seems to have fixed it for a number of user now.


#27

I’m finishing a fresh install and I’ll let you know !


#28

Woot ! got it working. Using VNC Viewer on my Mac. Needed to type organelle.local:5901 as address.
Now the serious stuff can begin !

Thanks so much !


#29

Did you previously install/run from usb or sdcard? I’d like to eliminate this from a possible cause.
( it seems unlikely , much more likely it’s an issue with the 3.1 upgrade, but as said before that’s harder to test)


#30

It’s been a while. But I’m 99% sure that I did a fresh install (meaning flashing the SD card with etcher), since I bought a bigger card especially for this a few months ago.


#31

@thetechnobear I’m still on the same SD card that you helped me partition before 3.1 (I have a note on another thread that says I was on 3.0 at the time, and I remember upgrading to 3.1, never did a “fresh install”). And VNC with screen sharing works for me. Hope that’s helpful!


#32

thanks… that means its probably something missing from the 2.x to 3.0 upgrade.
(and was different in the 3.0+ images)


#33

Hi,
Having problems with this on a 3.1 fresh install. Extra>TigerVNC will “run” but unable to connect. Wifi, OS version, etc is all good.

I think I have narrowed the problem with something to do with the script. Because I can run this and it works:
/usbdrive/System/TigerVNC/run.sh
But only after I enter a password and confirm it etc.

Any ideas? thanks


#34

Hmm fresh install worked for everyone else.

If your being asked for the password it’s something to do with the .vnc directory or the updated x script. both these things are hsndles during install but no idea why it failed on yours.
I’ve run it quite a few times in my Organelles and works fine everytime :frowning:


#35

Perhaps the way my thumbdrive is formatted? I had trouble on my chromebook/linux recognizing/modifying the FAT format and just formatted it the way chromeOS wanted it. Everything seemed to work that way but I suspect that thats the only divergence I had from the standard procedure of 3.1 fresh install.

So, trying again reformatting to FAT on osx Disk Utility.

But,
Trying to reinstall the vnc app again and
sudo rm -r /root/.vnc
yields
rm: cannot remove '/root/.vnc/config': Read-only file system
rm: cannot remove '/root/.vnc/passwd': Read-only file system
rm: cannot remove '/root/.vnc/xstartup': Read-only file system


#36

yeah you need to remount the filesystem to edit it using

seems unlikely its the filesystem (as long as you didnt try to expand the zop file, which would screw things up)


let me take a step back…

the fact that it works when you do run.sh manually, means tigerVNC is installed properly - thats good.

but it should not ask you for the password, as this has already been configured, and saves in ~/root/.vnc/passwd
I cannot see therefore why its asking you for the password.
(this is why i supply .vnc/config and .vnc/passwd so this step is not necessary)

the xstartup file is required, so that the HOME directory is set properly, this was a quirk i found when launching from the Organelle menu.


if you still having problems after a reinstall, Im a bit at a loss to why its not picking up the password file,
but what you could do is:

~/scripts/remount-rw.sh
/usbdrive/System/TigerVNC/run.sh

it’ll ask for the password which you can enter, but because the filesystem is available to write it will work

the other thing you can look at is stepping thru the run.sh script

you will see essential it does:

cp -R /root/.vnc /tmp
export HOME=/tmp
vncserver

the reason it does this, is that vncserver will fail to start on a readonly file system, so we have to get it to run in /tmp as home (a ramdisk) , but it then needs the .vnc setu (so we copy it)
this is why the xstartup then reverts HOME back to /root … so that the proper X desktop is configured properly.

its a bit of a hack due to vncserver expecting the home directory to be writeable (for logs etc)


#37

Hmm I am not sure what is going on either… Still the same (small) issue. It is hardly a hassle for me to ssh in and run the script manually for this to work, but it would still be nice to get rid of that step. Another flash of 3.1 and a FAT formatted thumbdrive. Running the script from the organelle UI still does not create a connectable server.

Running the script step by step:

[root@organelle ~]# cp -R /root/.vnc /tmp
[root@organelle ~]# export HOME=/tmp
[root@organelle root]# vncserver

then

You will require a password to access your desktops.

Here I tried ctl+c on the terminal instead of entering a password, and then it started and I was able to login with ‘coolmusic’.

Password:xauth:  file /var/tmp/.Xauthority_root does not exist

New 'organelle:1 (root)' desktop is organelle:1

Starting applications specified in /tmp/.vnc/xstartup
Log file is /tmp/.vnc/organelle:1.log

Again, if this is not reproducible for anyone else I am fine with seeing this as a quirk and am not too worried about manually starting stuff for now/mayberevisiting at a major update.

Thanks either way @thetechnobear for all you do.

EDIT quick question: how can I end a vnc session when I am done with it?
vncserver -list
doesn’t list any sessions but I am still able to login.


#38

One quick follow up:
After running the TigerVNC/run.sh manually once (simply ssh root@organelle /usbdrive/System/TigerVNC/run.sh), where I login and make a password in the ssh session. I can then exit the vnc window, kill the vncserver by
ssh root@organelle export HOME=/tmp && vncserver -kill :1

and then when I run TigerVNC from the organelle it works! I can enter in with password ‘coolmusic’.

I figured out how to kill the vncserver by running the kill command in /tmp like in the script. Is this the best way as of now to close the vnc server without rebooting?

If I press the red “exit GUI” thing on the bottom right during a vnc sessions things act kinda funny, where the desktop remains but the menu bar is gone. and any time you log in to the vnc again the bottom bar is still gone until I kill the process/server.

Again, this is no big deal just reporting it all!

other than manually having to run the TigerVNC/run.sh and the kill command above through ssh, everything is working beautifully on a very cheap chromebook with VNCviewer. pd is much easier to develop in directly in the vnc session than doing the same thing on my pisound setup!

just curious: are optimizations of pd in vnc done in pd itself, changing sizes resolutions of things in a config file, say? or are there options in TigerVNC (or the VNCviewer) to look at that can make this even smoother?


#39

Is it possible to use a raspberry pi to remotely patch the organelle over VNC?


#40

sure, there are lots of vnc clients for linux…

not sure what the advantage is to just patching directly on the Organelle though, given you probably are going to connect a tv/monitor & keyboard/mouse to the rPI, which you could as easily directly directly to the organelle :slight_smile:

but if it works for you , why not …
as stated in the first post, just look for realVNC or tightVNC both should work fine.


#41

rPi is set up anyway, together with mouse / keyboard. I like the Organelle to be untethered to USB hubs if I can at all help it. Cheers will check them out.