Using a wifi adapter

I got the Ableton Link external working a while back, but haven’t done much with it. It worked well so far, staying perfectly in sync with rest of devices on network. Here is the external:

1 Like

there you go!
including it in patches should be a button or wake when it sees the wifi

to get your wifi (or other network) connected at boot you can use netctl

what I did was:

  • ~/script/
  • use above to get an initial wifi/internet connection.
  • edit /etc/ssh/sshd_config, change PermitRootLogin to yes
  • change root passwd, so I could login remotely.


pacman -Syy
pacman -S dialog
wifi-menu -o   
netctl enable <profile created>

basically this, updates the pacman database, installs the dialog package (needed by wifi-menu), allows you to enter the wifi setup, then netcrl enable uses the created profile and boot time.
(if you have multiple wifi or ethernet you can use netctl to select different network profiles)

1 Like

that all worked for me but I also needed to run dhcpcd wlan0

I think this is what I did to fix that (I did some other stuff that I think was pointless so missing that out):

remounted file system as rw (./scripts/
systemctl enable dhcpcd
cd /etc/systemd/network
edited to change the name to wlan0

rebooted and test - worked!

the stuff I did that I think was pointless was the last post here

in passing:

how cool is it that my new little gadget has vim installed :wink:

this was my first proper encounter with systemd - I normally get my employees to do this kind of thing these days (for work stuff obviously) :slight_smile:

1 Like

little tip - guessing most of the advanced users here know this but I’m a fan of explicit instructions :slight_smile: :-

if you have your wifi working and install rsync you can just copy stuff directly to the organelle rather than moving the usb drive all the time:

pacman -S rsync

you can then rsync from your local machine:

rsync -rltDv organelle:/usbdrive/Patches/

the flags stop it trying to set the owner and group which since I’m logged in as root rysnc doesn’t like

I’ve got the organelle setup in my .ssh/config so it uses user ‘root’ and sets my x forwarding so you may need to tweak the rsync to add a user etc depending on how you have it setup

you still need to select ‘reload’ on the main menu for it to pick up patches of course

so Ive been test TB22tb9 , to check that a vanilla organelle can now access X/ssh without resorting to using an HDMI display for initial setup
… so the goal is: fresh organelle, insert wifi card, run startwifi, be able to login/run X remotely
the good news is this now works :slight_smile:

but whilst doing this, I had a pretty frustrating time, getting startwifi to work, as theres absolutely no feedback as to whats going on… so Ive improved the start wifi script (attached)
it nows gives feedback to the oled whilst its running, and also produces a logfile for each commend in /usbdrive/wifi_log.txt, which gives you a chance to check when theres errors (without having to attach to a tv :))

(I also fixed an issue: you need #!/bin/bash at the start as <( … ) is specific to the bash shell) (509 Bytes)

still some room for improvement:
a) check return codes, so the oled (OK) means more than the command ran
b) display IP address at the end.
c) I also think probably we are better with a wifi config file, such that users cannot accidentally ‘damage’ the script whilst entering their username / passwd.

anyway, perhaps take a look and decided if you would like to update the C&G version

Thanks for this improved script, much better to see what is going on! I remember trying to get the thing online when I didn’t have an HDMI cable, only to finally realize I had edited the file with TextEdit on a mac and it changed the quote characters around the password in the wpa_supplicant command to the unicode ones. this would be alleviated by your improvement ©.

what do you think a good mechanism for returning a general ‘network connectivity’ status? I use this following script to spit out the IP address to OLED using some fragment I found. It returns the IP address when up, but I don’t recall what it does when not online.

the two scripts could be combined, so if the network is already up it just displays the IP (and ideally ssid, hostname, whatever else), otherwise it does the connection sequence.

IP (1.1 KB)

or might be better for the wifi connect script to also use netctl and wifi-menu (this one is leftover from early Organelle proto running Yocto linux).

I realized wifi-menu is a shell script that makes calls to the dialog command for selecting a network and entering password. These calls could be replaced with scripts that did the same thing on the OLED: select from a list of networks, and enter the password using the encoder (annoying, but only have to do it once, or it could check for a file on the usb if you wanted to just put password there).

Have followed instructions from @quilime and tried running @thetechnobear 's StartWifi
No luck with OTC_Web though… is there more I’m missing?

WiFi should have some more love, but I understand it’s a big topic with lots of “things”.

Today I got it running with @thetechnobear ; just entered my SSID and password

Things I point attention to:

run latest 1.2 OTC_installer
…startx - edit and execute StartWifi (file run dot sh)
when in OTC the OSD screen can help visualise IP address
wifi adapter? what is yours? ( I got the official pi - white adapter)
try with no USB hub in between ? or nothing else besides wifi adapter

Hope some of this helps :wink:

p.s. ETC manual also refers to a way to have Web Console (OTC_Web)

1 Like

Cheers for your response mate
Ah - so all the commands are to be typed into the black background console on startup? Or no?
I typed them out into the white one on the desktop accessible after startx, enter etc

I already have OTC up and running successfully - just not OTC web, will running the new OTC_Installer complicate things?
I’ll have a look at the ETC manual :slight_smile:

No, Misunderstood… I just edit the file and execute it with Organelle connected to a screen with keyboard/mouse and so startx.

You need last version :wink:

Sorry, I don’t understand. Is it ok to overwrite using the latest installer? I thought @thetechnobear said this caused some diagnostic issues.

I think I understand the StartWifi issue - I must have been running a blank unedited version of it without info in there for my wifi network.

Yes it’s OK @Wannop I just did it from 1.0 to 1.1/1.2 that is the version supporting OTC_web
We have OTC running with no problems!

1 Like

Working! Cheers my dude!

1 Like

getting the Wifi seems way overly complicated to me at this point.
Have OS3 running, got the recommended wifi adapter, changed the name on the wifi.txt,

Do I have run scripts, modify codes, hack things, what do we do? i’m not a Linux expert yet

On the organelle select the Settings> menu.
Then select WiFi Setup
You should now see your wifi name, select that and it will connect.

thanks for your response. i did get that far, still says problem connecting, gonna keep at it…

got it to connect on the wifi at my studio, but couldn’t get it at my house… sweet! now where was that stuff i read on here about connecting with Link…

is all this done on a text file on the Organelle’s usb stick?