Setting up wifi on the Organelle


#1

Now it is super simple with OS3, any chance of a tutorial for those of us who don’t find it intuitive? How do I set the network name, for example?


#2

you’ll find a wifi_config.txt file on your usb drive.
you need to just edit that (on your mac/pc),
enter the SSID (network name) on the first line
enter its password on the second.

and dont add a new line at the end of the second line… i.e. the file needs to be 2 lines.
(if you add a new line it will complain about the file format)

once you have done that , insert in organelle, then
settings->wifi setup-> select network name , click it and it’ll try to connect to the network


#3

ok i just saw this thread after posting in one of the other ones. hopefully us wifi raspberry newbies can get this to work… I can’t yet after following these instructions… gonna keep trying…


#4

Do you replace the text with the network name and password on the 2 lines or do you add both after on each line.

Network Name Netgear06
password 1234password

Or

Netgear06
1234password


#5

the latter


#6

thanks now its working


#7

Something isn’t working for me- I keep getting “problem connecting”

I edited the wifi config and changed it to have the network name on the first line, password on the second. So for example if my network is 1234 and pw is 4321:

1234
4321

Am I wrong to have removed the previous text?


#8

I’m having the same problem as @danger_mintz, username and pass on correct lines, correct format, but still says “problem connecting.” I bought the official organelle wifi adapter thing so it shouldn’t be the adapters fault.


#9

What security protocol are you using on your WiFi router?
It should be wpa2 personal / tkip+aes
Also check the wireless mode matches your stick eg b, a, n - or put in mixed mode.

DHCP must also be available on the router.

These are the default these days but perhaps for some reason they’ve been changed on your router

If you have other things attached to your network you can also check how they are configured.


#10

I have just been able to figure out what was wrong for me.
My router is dual.However, the 2.4 and 5 network have different names (as is better practice anyways)
Make sure that you are typing in the text file on Organelle, the right name for the 2.4G which is very likely not the same network your computer is connected to.


#11

Also, if you are trying to use LINK, make sure your computer is also connected to the 2.4 network


#12

I cant get the wifi to work. I git a cheap wireless USB adapter from amazon, its a TP Link nano usb adapter. Changed the wifi.txt with right name and password, but it says trouble connecting. Does the organelle need drivers? Should I get anothet wireless adapter?


#13

I have got a CANA kit for $10 off Ebay.
Make sure that the network name you are inputting in the text file is in fact the 2.4G and not the 5G.
If yo have a dual router, your computer will be typically connected to the 5G


#14

I have a mobile network router, I could not find any setting for 2.4 or 5G…
But the light if the usb adapter does not even go on when plugging it into the organelle. Can I install drivers on the organelle? On my mac it workes only after installing the driver…


#15

i think* thats based on the RTL8188EU which will not work on the Organelle, see here
this is why the rPI wifi stick is recommended see the ‘main’ wifi thread.

(* Id need to know the exact model/chipset to be sure, but thats what a quick google search indicates)


#16

that’s weird… my edimax 7811Un seems to be based on RTL8188, but works perfectly fine with my organelle.


#17

Ok, thanks a lot for clearing that up! I’ll send it back and get another one. :confused:

The TP-Link is indeed based on the said chipset. The Edimax however is based on the RTL8188CUS, maybe that works?

If it really works fine, I will get that one instead.