Setting up wifi on the Organelle


#16

that’s weird… my edimax 7811Un seems to be based on RTL8188, but works perfectly fine with my organelle.


#17

Ok, thanks a lot for clearing that up! I’ll send it back and get another one. :confused:

The TP-Link is indeed based on the said chipset. The Edimax however is based on the RTL8188CUS, maybe that works?

If it really works fine, I will get that one instead.


#18

I tried what you suggested but when I open the WiFi file I get three other files, then i must have done something wrong because now my Organelle instead of looking for a network i get this error mesg. “Error with wifi.text please check file is in the correct format” I also made the mistake of not writing down the original text inside the WiFi files. I wonder if someone can help me figure this out please see photos.


#19

its simply…

mynetworkname
mynetworkpasswd

don’t just the two lines, don’t add a new line to the password
if you delete the file, the next time you start the wifi setup if will create it again


#20

It worked! thank you so much, now it went back to the original settings, Do you happen to know where or which file name I need to go in to write the SSID (Network name) and password,because Organelle has there files
Wifi Config
Wifi
Wifi log
So if is not too much to ask.
Thank you.


#21

the file Wifi.txt


#22

The files in Organellle usb for Wifi are the ones in the photo. I do not have
Wifi.txt
Or I need to creat one
As you can see I am new and not good at all with programming, so please explain exactly what do I need to write once I am inside the file.
Thank you,


#23

its the one you see as wifi

in windows you need to turn on file extensions to see the the full filename which is wifi.txt
you can also see it if you bring up file properties.
any how no matter, that is the file you are after

(you can delete the wifi config… to avoid future confusion :wink: )

ive already told you in my post above… and given i dont know your wifi network name or password, I cant get any more specific than that :wink:


#24

I appreciate your your time and help! :slightly_smiling_face:


#25

unfortunately having the same wifi trouble / problem here
i think i already tried every possible thing i found here…
help!


#26

What WiFi adapter are you using? have you been able to connect to any other networks, or is this the only one you tried?


#27

thats already my second one…firrst was TP-Link this here is Asus


#28


#29

is ‘U’ a different network, or is it the previous network not showing up correctly?

anyway, I’ve never tried those adapters, so can’t say if the problem is with them or not. many WiFi adapters will work, but many will not, so it is recommended to use one that is known to work.


#30

The U just happened today…
just as you say its…not showing the Network correctly…its a known bug?

what should i try next?

maybe a fresh install? or a way to install the driver in terminal inside the Organelle?
there must be a way its archlinux and there is a terminal like in osx
you just need the right code;)


#31

@slimak What is the chipset?

Some more info here:


#32

its exactly one of those for even less then 10 euros…its a

Asus USB-N10 Nano

is it this chipset? unfortunately i don´t have the package anymore
https://wikidevi.com/wiki/ASUS_USB-N10_Nano

lets hack it…


#33

this says its a RTL8188CUS
https://wikidevi.com/wiki/ASUS_USB-N10_Nano
you can see on this page its supported from kernel 4.1x so the 3.14 kernel used will not work.

thats said this is not gospel… if you run my DiagnosticLog tool, this this would give us the definitive answer.
though probably not much point… as if its not working, then the most likely reason is the kernel does not support it.

this is one of the reasons for my 'upgrade project’

ive already found on this project that wifi sticks that did not work on the current OS work perfectly on the this newer OS… so the future is bright :wink:

however, this is a little way off yet… i need to complete the packaging, and then need to do extensive testing to ensure that the performance is at least comparable with the current OS.
(early indications are good, but more testing required to be sure)
I guess, i will release this as a ‘beta’ when its close, but Im not at this stage yet…


#34

DiagnosticLog Tool says :

diag_log.txt.zip (3.5 KB)


#35

ok, its using a Realtek RTL8192CU

a quick search on google, shows countless people having troubles with this, and having to recompile the kernel with fixes to get it to work.

as you’ll see in my above thread , and also this one, we dont have access to the correct headers for the current build… so this is not really an option (and certainly not one Im personally willing to explore)

so unfortunately, my only suggestions are wait for the new OS (assuming we get there ) , and get another wifi stick as per recommendation in the meantime… which costs < $10 :wink: