Change sample rate on Organelle?

Hey guys!

A while ago I asked about changing sample rate on Organelle and at that time the sample rate of Organelle was located in a read only file.


And I was just wondering, since there have been many updates to Organelle since then, if it was possible to do this in a simple way today?

I would really like to run Organelle at 48khz.


you can now put pure data options in pd-opts.txt in either system directory or patch directory.

Okay cool. So I just find the one in the system directory, copy it to my patch directory, change sample rate, save it and that is it?

That sounds doable :slight_smile:


no, there isn’t one…
you just create one with the pd command line options you wish to use.

it will automatically override those that are passed in when we start pd

Ahh okay. I am not 100% sure how to do that.

Do I just follow the guidelines for working with Pure data from terminal?

I simply make a document called pd-opts.txt. And inside that object I put:
-r <48000>

And that is it?

Guess I am just going to try a bit later tonight and see if that works.

just -r 48000 ,
bare in mind it’ll take ~10% more cpu resources, so you may also need to change the audio buffer to stop audio artefacts.

Cool will try tonight, didnt have time last night.

Yeah I am aware of that. If the patches are not too heavy it wont matter that much. I guess I will find out how far I can push it without changing the buffer :slight_smile:

I tried running a patch at 48khz but i had graphic issues with the OLED screen : there’s a kind of VU-meter in the patch and when running at anything above 44.1khz it becomes glitchy (or i would say it’s clipping) like a framerate issue… i thought it was about finding the right Delay and Block size setting but … EDIT : i found it! so, obviously when changing the sample rate it changes also the behavior of PD objects like the filters or in this case the [env~] object that was sending values to the screen too fast (i guess), so to fix it i added a [sig~] -> [snapshot~] to the proccess, with a [metro 40] to let only 25fps to pass. It that might help someone… :v: