ETC change text on text modes

Hello, first wanted to say I love the ETC!!!
Just getting under the hood with the modes, I have no python experience. Trying to figure out how to change the actual copy that comes out on the text modes, as is it just says “text”. Any help would be greatly appreciated.

One more thing, chrisk’s image modes are amazing!!! Kept me up late into the night tayloring images to use…

which mode in particular? it varies…

generally you have to edit the python code, and either find the word or string in there, if you just alter the words then you shouldn’t break anything …
you can do this in etc_web, and do “save new” so you don’t overwrite the original mode.
(and then later you can rename it on your pc/mac)

Note: spanish flash cards has the words in a separate python file (, which you will need to edit outside of etc_web, ie. load the usb stick on your pc, and edit it directly.

I see a lot of words in the file but when I try to use the mode it says something like, words found, none or something. Has anyone gotten this to work on OTC?

Worked for me last time I tried it

Did you edit it, if so redownload and try again

Works for me as well, I would follow technobear’s advice, I was playing around with the code of a particular mode so much it wouldn’t render properly, so I keep a factory modes back up folder, just in case.

happy ETCing!

Redownloaded Spanish flash cards and I’m getting the same error messages.

so you get this error, even if you do not edit it?
if so, something is a bit strange, as its working for everyone else, on both etc and otc.
I can assure you there is no issue this mode on OTC, when downloaded ‘fresh’ from

if its still the same error… my first step if its still failing is to double check you have really replaced your edited copy with the version from the website, as most likely issue is somehow this has not been done correctly

fyi: the error your showing indicates that the ‘words’ array has not been initialised (hence why its is None)

obviously to help further Id need to see the code that you running
(this is why you have to be 100% sure you are running the right code, we dont want to waste time, trying to debug something thats not being run :wink: )

I deleted again, but now I can’t seem to find the mode to download on patchstorage? is it gone?

not sure they were on patchstorage, but you can grab them all from, which in turn points you to