Major crash

Hmmm, not so good. Running the latest Beta and my Organelle has just failed to load. Checked the on screen log and seems like there are a lot of issues highlighted in red. Was just going to go through a reinstall on the SD card but is there anything I could do to help the development side of things - @thetechnobear / @oweno?

Probably my own fault, was running near the RAM limit at times today and the unit froze a few times and had to just pull power out without going through the shutdown procedure. Is there any way to view RAM usage whilst using the Organelle similar to checking the CPU load?

Tried starting it with all but the power supply unplugged? I’ve had interference when starring with unpowered HDMI adapters before that resulted in the 99% freeze.

1 Like

Thanks for suggestion but no joy. :frowning:

probably filesystem just thinks its been not shutdown cleanly…
odd, since the sdcard partition with the os is usually readonly.

id follow the instructions :slight_smile:
so use journalctrl -xb to see if the logs say anything interesting

then after then do systemctl default , see if boots up properly

note: if you have been saving files to the sdcard and you plan to reinstall the os image,
you will want to get these files copied off first to the usbdrive.
id guess this can be done by logging in under emergency mode, then copying files to a usbdrive
you may need to mount the usb stick manually , you can do this with ~/scripts/

Tried those but to be honest wouldn’t know if the log said anything interesting as it’s all Greek to me!

Could the SD card files not be accessed using a reader on another computer? I wouldn’t know commands to copy files off otherwise. I was feeling pretty tech savvy for a while but brought back to earth with a bump! :grin:

the sdcard can be read by a computer than understands ext4 filesystems, but thats basically linux only… so if your running windows/mac, then no by default they wont read them.

all you really need to do is:

login as root, by entering the password … which is

the type

cp -R /sdcard/Patches  /usbdrive/Backup

this will copy all patches from /sdcard to a directory on your usbdrive called backup
just make sure you have plenty of space on the usbdrive.

(you could zip them up if you want, but thats probably not necessary)

you should be able to capture the log with

journalctl -xb > /usbdriver/logfiles.txt

and as i say, id before you decided to rebuild the image, its worth a try doing the setting to default state with

systemctl default

or it implies Ctrl + D on your keyboard will also work … but perhaps its saying it cant get into default , in which case yeah , its rebuild time.

Really clear instructions, thanks! :smiley:

let me know if you get the logs from above… though frankly, I think they’ll say you have a corrupt file system, but thats still useful info

what were you doing beforehand?
had you run ~/scripts/ beforehand… or installed something without rebooting?

its pretty clear why your patch caused the OS to crash (se my post on your other thread)
the only thing that is not clear is how did the root filesystem (which is read only) become corrupted?

only things i can think of are:

  • the rootfs was not readonly, due to some thing asking for write access (like an installer)
  • the /sdcard partition was corrupted, (which could happens its correctly writable) and somehow this then stops the boot sequence. (perhaps just for maintenance)
    (however, if thats the case, Im surprised if you were able to mount it to copy stuff to the usbdrive… but its possible that ok, and it might have given you a warning)

anyway, I really need the logs to know which has happened… and to be able to investigate further.
(and see my other post on your patch thread about issues with your patch)

As well as crashing the OS, I did two other things:

  • Tried to unzip a file on a USB stick that was too big to unzip without realising (using the option on the hardware rather than the web servr) and therefore failed (could this be classed as an installer?)
  • Forget to unmount before removing the same USB stick :roll_eyes: (oops - it’s been a while since I’d used the USB with my Organelle)

Will see if I can retreive the logs.

nope, neither of these make the rootfs writeable… just likely to corrupt the usb stick.

Basically the Organelle is goosed, none of the suggestions above was a successful. No problem I thought, I’ll reinstall the OS. When I put the 16GB card into my PC it asks me if want to format, but it says the capacity is 3.63GB. What’s going on?

The computer might be reporting the size of one of the partitions on the card, not the physical memory. I’d ignore that message, download OS v2.1 and flash it using etcher (sorry we don’t have a v3 image for download, but you can run the v3 upgrade after flashing). This should work, otherwise I’d be suspicious of the SD card itself…

1 Like

Hey @oweno, you were right (obviously)! I’m back in business. Thanks!