MIDI Connectivity: Organelle, iconnectaudio4+, and iPad


OK i have read all the midi related threads over and over and watched the video of advanced midi setup and tried… I have no idea why I can’t get this to work:

basically i want an ipad and an organelle to converse in midi. I’m using the iconnectaudio4+, which is an interface that supports usb midi from the ipad, laptop, desktop, etc over one of two usb connections which also carries audio, and also from a separate usb midi host port and 5 pin DIN midi i/o. …i could send a pic.

i can’t figure out a way to run a usb cable from the organelle and into the host port (would be the kind of usb to usb used for hard drives… it doesn’t work) on the iconnect. SO i’m using one of those 5pin midi to usb adapters.

and here is maybe the most annoying detail: I can get midi out of the organelle into the ipad… but not into the organelle from the ipad (or from a midi keyboard connected to the host port on the iconnect).

I’m on 3.1. i tried alot of different scripts, .txts from other threads…

can anyone please help?

C & G Midi controller for the Organelle

It’s the idiosyncrasies of wonderful iConnectMIDI iConfig… You have to slowly, port by port make your way :wink:
Try to understand “they” way of connecting things.


the usb-usb thing


but i have!

could you give any more insight than this?

I’m only connecting to iconnect via usb midi adapter


What iOS app have to tried with?
Sending MIDI from iPad > OG


ios aside i would like to have it work from midi controller to begin with, and that is not working.


@kee, Please tell us more (“It’s not working” doesn’t really help anyone help you).

What is the make/model of your USB MIDI device? Is it class compliant?
Does your USB MIDI device show up in the Organelle’s under MIDI settings on the Info page? If yes, which channel is your Organelle set to?
Which patch are using?


stated above but again
model: iconnect audio4+,
is it class compliant: yes
yes midi device shows up on info page, when connected to din midi output via usb midi adapter shows up as usb midi adapter, tried multiple channels
patch: tried several, as long as midi output is enabled i am able to get midi notes sent out but none are received

also i said a lot more than it’s not working to begin with… did you read my post? i mention what i want to do, what i have read in trying to figure out how to do it (should i include links, most threads are obsolete after the midi updates in os3), what device i am using, what organelle OS, what i have tried already. i ask several alternative questions… i did not say “it’s not working.”
maybe you are responding to someone else.


I don’t have a iCA4+ , but…

plug the organelle into iCA4+ device port 1, so the square one.
then on OS 3.1 , settings ->midi setup -> device … select the device, you should see the device listed, twist the encoder if there are multiple.

whilst there also check that midi channel in is set to what you expect, and also midi in is active.
once done, select hit save.

then run a patch… (chose a simple on like basic poly to test with)

your iPad should be in the other device port (2)

then you need to check in iCA4+ that midi is being routed from the device port 2 to device port 1.

to help further what we would need to know is which of the above steps is not working.
e.g. do you see the iCA4+ in setting midi setup?