Orac: Bug reports


#21

I found a small bug in the U-chordroll module. One of the chord notes (the third one from left to right, when you open the patch in pd) isn’t updated with the correct root note. Easily fixed by changing “r croll_root-$1” to “r croll-$1-root”, so that it looks the same as the other chord notes. See attached image for clarification.

I’ve gotten brds to lock up one time: I had a quite intense sequence running, and was changing Shape rapidly. my chain was arper > chord roll > braids. I can’t repeat it, and sadly didn’t think of noting the values on the screen when it occured. sorry that I can’t be of more help.


#22

thanks, will check that out.

brds - i think there is a combination of values which blows up the MI engine, but I just havent figured it out yet.
I think its probably some value that a particular shape does not like… so when the shape gets changed to it, it falls over… its not new/unique to orac, but I think now more people are playing with brds we are just tripping over it more frequently.


#23

saving does not work for me. i watched “Orac: modular synth for organelle,” on youtube–the part where Mark saves the patch–i watched over and over. I do all the steps. it sometimes seems to work but when i turn off the organelle and back on, no dice.
can anyone please help?


#24

You need to do preset-> update , then save


#25

thank you. I wondered if it were an order of operations thing.


#26

Hey,

totally buzzing at the prospect of Orac. I have been playing with it and I am not sure if this constitutes a bug but the Polybeats module does not appear to contain any actual beats? In the demo video’s they all show drum modules but I cannot find any within the Orac patch.

Probably me just being ignorant / stupid or both but does this make sense to anyone?

Thanks in advance :wink:


#27

pretty sure one of the samplers is full of drum sounds! if not you can always load some up

also if you have decent speakers download S_TITAN from patch storage!


#28

@junklight thanks for the speedy reply chap.

I will keep fiddling (the fun part) I am downloading S_TITAN now. How do I load it into Orac? Is that what @thetechnobear covers in his ‘module developers guide’ video?


#29

I seem to remember that s_TITAN needed copying across unfortunately - so copy it to wherever you have patches (I’ve got everything on the SD card and 'scp’d it across)

worth it though :wink:


#30

Off- topic:
I think that the pitch parameter in clouds should not be stepped, but should be capable of pitches in between perfect quantities. When lfo modules appear, this will give greater opportunity for an organic feeling of motion in sound.


#31

I noticed something today that I think is worth mentioning here:

I don’t think this is specific to a particular module/modules (so long as it’s S), but just to be thorough - I’m in 3x3+1, modules loaded 0-basic poly 1-analogstyle 2-czz
If I hold down a note, and navigate to any module in a higher slot than the current module, the note will stick (i.e. not release). It doesn’t happen when switching to lower number modules.
It is repeatable. You could ask why on earth one would do this. To be sure, the first time it happened by accident - but I can see it happening to someone who doesn’t know (or even someone who does, in the heat of the moment, if you’re playing the keys, and switching around a lot). If it’s quick to fix, prob worth it for 1.1, but if consuming, may just be worth making everyone aware of.

A secret ‘latch’ feature would be cool though :laughing:
edit: just realized there is likely no way around this as the synth earlier in the chain doesn’t get the “release” signal :man_facepalming: - sorry for the pointless post!


#32

The tone paremeter in the Rhodey’ module doesn’t affect sound. Can anyone double check this?


#33

double checked - same on mine
as well there are other inconsistencies between C&G patches and the “modules” that share the name (basic poly for one, which I’ve mentioned elsewhere in the forums).
@thetechnobear has done the bulk of the work and given us a real gift with orac, so I think it’s up to some other PD savvy members that want to address things like this. I wish more than anything that I knew how! (I would be glad however to comp people for their time for working on specific issues if that might be an option at some point going forward) :smiley:


#34

ok, whats happening here is… the notes from the keys get sent to the active module, and if midi thru is enabled on the module, it will continue down the chain.
when you switch modules with the key held down, then basically the note-off gets sent to the ‘new’ active module.
so yeah, I left this as kind of a latch.
because the alternative would be to kill all notes, and that also can be seen as inconvenient at times.

(ideally I think a sustain pedal could be used, then the action could be very defined, but not everyone has a sustain pedal to use with the organelle)

the one that can be a bit more problematic, is if you have a sequencer further up in the chain, thats playing notes, and then you switch the sequencer out, before turning it off - this can leave hanging notes.

I’ll have a look at rhodey when I get time, I need to compare the patches (preferably running) side by side, see if Ive missed something, or more likely got the parameter scaling incorrect.


#35

Thx for this ^
Also noticing something else that may be worth looking at (thinking it could be related to above)
module setup (new 2) as follows (from 0-9):
Euclid, Basic Poly, Panner, Punchy, Analog Mono, Reverb, Arper, Rhodey, Clock, 3x3+1
When switching from “new 2” to “Default” (never updated), I get no sound on the Basic Poly in that preset. Also, when switching BACK to “new 2” Punchy has flipped to “Default” (I did update preset and then save, so not a problem with save procedure) and I get hanging notes.
At first I had Euclid running a sequence when switching back to default, so I tried it again after turning the “# notes” to 0 on all four sequences (same result, no sound on Basic Poly in “Default” preset BUT when switching back to “new 2” now NO hanging notes).

To be clear, I am loving orac - not complaining here! just some user feedback that may be helpful going forward - tried to troubleshoot quite a bit before reporting in hopes of saving you time :smiley:


#36

I’ve fixed a small issue in presets that may have been the cause of this.

Given I’ve done quite a few fundamental changes , I’ll probably put out a beta before the next release, so users can re-test any issues they have encountered, to see if they still exist.
(Also so many comments on 1.0, it’s hard to track everything)

I’ll admit now it’s summer here, and other little projects ive been playing with - I’ve not spent much time in Orac 1.1 in last few weeks, and I’ve got a few busy weeks ahead - but have no fear it is very much still in the works.


#37

quick bug report involving brds mono (realize there have been reports on this, but thought this might be helpful since the parameter values are different and easy to dial in and it seems consistently repeatable):
in default preset, loaded into m2 slot (after basic poly)
values on first page 27/28, 100, 100, 24
happens when playing and scrolling through shape values, at both 27 and 28


#38

not really a bug per se, but, noticing Basic Mono and Basic Poly modules aren’t level matched.

I can see why this may have been done intentionally (many notes will be louder than one)

For me it makes more sense to match them and let the user adjust from module volume. If you/others agree maybe this can be an adjustment for 1.1 :smiley:

edit: ok so the real issue I’m having I realized is more related to gain staging, which I know is being revised for 1.1 - that may make this a moot point :thinking:


#39

I’m new to the Organelle so maybe someone can advise? I am checking the JSON file in orac for how the presets are saved and in various modules in different chain formats I have added the punchy seq.
However it does not load because the name is not saved correctly when hitting save / update preset. The only way I could save the punchy seq in a preset was by correcting the JSON.
For example this happens >
“m0”: {
“moduleType”: “U-punch”,
“params”: {

Is there something I can do to fix this elsewhere rather than having to edit the JSON file?
cheers, J