Orac: Bug reports


#41

Thanks for replying! I’ll try to explain better… I read the associated posts thoroughly before asking anything as I wouldn’t want to waste anyone’s time :slightly_smiling_face:

I’ve successfully saved a preset with a chain setup using m9:3x3+1. In first position for each set of 3 I have chosen the punchy sequencer so I can program simple drum, bass and keys sequences all running together.

The problem is that after restarting Organelle and checking the preset is saved correctly I noticed that the punchy sequencer in the first position for each chain was not loading and I end up with a blank slot. So I had to add it again everytime I started up the preset. Kind of irritating so I tried to fix it by having a look around here and there…

When I checked the JSON file for preset configuration I immediately noticed that the name of the sequencer was > “moduleType”: “U-punch”, (this example in the first slot “m0”: { ) - so it was saved incorrectly and I believe this is the problem why it does not load because there are no modules with this name - it should be saved as > “moduleType”: “U-punchy”, not > “moduleType”: “U-punch”,

So I was wondering if there is a better way to fix this other than having to edit the JSON preset list?

Hope this is much clearer?
kind regards, J


Orac : release 1.0
Orac : release 1.0
#42

ok, the issue is with the punchy module… id fixed it quite a while ago so had forgotten!

in
modules/U-punchy/module.json

you will fine the name specified as U-punch, change it to U-punchy, and then saving presets will be correct.


#43

Great! thanks for your help - I will update the file as you suggest.


#45

I read this but mine is named correctly. This also happened with polybeats.
i reinstalled Orac as well but no luck. Any other ideas


#46

no your files show it exactly incorrect :slight_smile:

you need to update U-punchy/module.json, to have the module name as U-punchy
then you need to rebuild the preset, after restarting orac.

the issue is , the name in module.json does not match the directory name, and unfortunately what happens is:
when you save a preset it uses the name in module.json,
but when you load a preset, ir uses that store named to load the module from the directory.
so when they mismatch it doesn’t work.

I didn’t know during testing as its was a simple typo, and one I only appear to have made in one module out of quite a few :wink:

really I don’t need to store the name in module.json, but when I was developing orac, at the start I had modules all in one directory, and it was needed , but then when I needed more flexibility I moved to different directories and forgot to remove the attribute in the json file.
i’ll fix this in a future release :slight_smile:


#47

ahhhhhhhhhhhhhhhhhhhhhhhhhh
yes yes yes
thank you so much.

bless you


#48

thank you!!