Organelle OS 3.1 TB Beta

time for a new beta :slight_smile:

the main focus of this beta is to resolve issues that some are having installing 3.0 on macOS.
so Id really appreciate those having issues with the 3.0 release, to try this release and let me know if it resolved their issues… and if now I will work with them to find a solution in this beta cycle.
… your participation is very useful, and will Im sure be appreciated by the community, as it will help others too.

BUT to sweeten the deal, Ive also made some improvement to the midi setup and handling, including separate midi channels for input and output, omni channel input and improved device selection :slight_smile:


  • improved installer for macOS
  • dont show ‘hidden folders’ for installs (cause by macOS)

Improvements to midi

  • midi in and out separate channels
  • midi in omni channel support
  • midi in/out disable
  • improved midi device selection
  • use alsa by defaut
  • allow additional midi connections

pedal setup

  • allow fine tuning of expression pedal
  • use footswitch to switch patches

(details on pedal setup here)

Id appreciate feedback on:

  • installing from USB on macOS.
  • any new issues with midi… lets focus on compatibility initially.
  • pedal support

background on macOS installation issues with 3.0

just a little bit of background…to perhaps helps some people test.
with 3.0 some MAC users that are upgrading to 3.0 from a USB drive , are getting ‘file corruption errors’.
this is being caused by some hidden files that the mac creates, and places on the USB drive, which the installation is not expecting.

this beta, should detect these and ignore them.

also if a corruption is detected, the installer will now create a file on the usbdrive called upgrade_log.txt, in the root directory , i.e. /usbdrive/upgrade_log.txt
so if you notice an issue please upload this somewhere, and report the contents here.

Its really important this is tested, as the reason this bug has slipped thru 3.0, is I do not get the issue on either of the macs I use (ive tried on 2 different macs)… I do not know why, perhaps version of macOS im using (10.13 , but was 10.12).

background on midi

this release now uses ALSA midi by default, this has quite a few more options that the previously uses OSS midi, including allowing us to configure multiple input and output devices. (details of which i will cover later)
the new implementation also allows for midi setups to be specific to patches, which can be useful for some kinds of patches.

note: MIDI-Config.txt is no longer used for configuration.

change log

  • b1 - 27/Dec/2017 - initial beta
  • b2 - 9/Jan/2018 - fixed OMNI for knobs and pgm change, fixed issue for patch directory
  • b3 - 16/Feb/2018 - new pedal setup, improved midi setup

Wow that was fast! Awesome! So this new midi support. Have i understood it correctly that you can now disable the kyeboard going directly to midi out, and instead make a manual midi out within the patch. Which makes it much easier to turn that on and off within the patch?

Problem free. Updated via USB stick using an iMac running High Sierra

1 Like

yes, Midi Output disable, makes the midioutgate false, so no midi is output via the mother.pd patch.
however, of course you still use midi output pd objects to output midi
(the same is true of Midi Input disable, which disables the input of the midi in the mother patch, but again you can do explicitly)

I was hoping that the new beta will fix the MIDI issues I’ve been having since OS 2. I don’t need MIDI on the Organelle that often and when I do it’s MIDI clock in that I’d love to see work. Seemingly it’s all good: the Organelle recognizes the device that’s sending clock, MIDI out/in channels are correctly set, still no clock in. Maybe I’m missing some pd component or something. Am I? Any advice will be much appreciated. Cheers!

midi clock (or any tempo sync) has not traditional been part of mother.pd…
so this would need to be fixed in the patches.
perhaps this is something that needs reconsidering? though still then patches would need to be updated to reflect any new mechanism

Had me a new 32GB SD-card fixed with an OS partition and another for patches.
Got it all working upgrading from 2.1 since there’s no image up yet for 3.0. Also changed the root password and enabled sshd root login. Add a password for my wifi network and got that working. So all was fine.

Today I downloaded the 3.1b1. Enabled the webserver on the Organelle. Uploaded the 3.1b1 update as a zip-file to the sdcard’s patch folder. Selected upgrade in the patchlist on the organelle. Upgrade completed but reported back that something went wrong. Forgot to write it down but will check if there’s any upgrade log file available on the sd-card later. Rebooting the Organelle and all seems to work. It also reports v.3.1b1 on the infomation page. But… I can’t login via ssh anymore. I can still connect but it won’t let me through with the password I set earlier.

First, is this way of upgrading a viable path, using the sdcard and skipping the USB-drive?
Second, does it in any way fiddle with the root password?

Just want to add that I’m eternally thankful for these added features and all the work that has gone it to making it happen.:smile:

yes, the password is reset to ‘organelle’ (this is so that ssh works ‘out of the box’ )

yes, you can copy also copy the upgrade file to the patches directory on the sdcard as well.

if its upgraded to 3.1b then i suspect there will not be any log file… and yeah, id need to know the exact error to be able to follow up :frowning:

Yeah. I figured out what you mentioned, but also by having to re-edit the sshd_config again for PermitRootLogin.
But, the password ‘organelle’ was new to me. Didn’t even try that one so thanks. :smiley:

And nope,.there was no upgrade_log.txt in my /sdcard/ folder. And I didn’t have the USBd-drive attached when I performed the upgrade so no file there…

I’ll try re-upgrade later tonight, if the upgrade process will allow me tosee what happens…

I see, thanks. Now I recall that MIDI clock in works with some patches. So this is patch-related. I can live with this. :slightly_smiling_face:
Thanks again!

thats unnecessary , this is already done by the 3.0 install (see /etc/sshd_config)… (Ive just tried on a fresh 3.0 install)

I suspect its just the password…
to be clear… on my organelle , installed a clean 2.1 image, upgraded to 3.0 , started my wifi (from wifi setup) , logged in with ssh root@organelle password organelle. … no change necessary.

My changes wasn’t present in the sshd_config file anymore so I had to explicitly modify the ssh_config file again to permit root login. I’m 100% sure since it was only a few hours ago. :grinning: Maybe I’ll redo the whole process tomorrow and hopefully it was only a one shot problem.

Updated from 3.0 with no problems with a mac. The midi menu looks perfect and I have put in a switching system in my patch between local control and noteout. Will have to check when I get back to my studio but looks promising, just how I wanted it! Thanks!

Thank you so much for doing this. Just tried it but got the same message as before with the os3.0… :sweat:

Thanks!! updated from 3.0, used web server to upload 3.1 zipped, unzipped and installed all good.
I had some “ghost files”, on the USB drive; they are gone now :wink:

Thanks for a “sweet” MIDI Setup menu. All seem to work as described; MIDI device lists and one can choose what controller to use, nice !!

How about combine controllers?, say two keyboards? (umm maybe in patch… will check later)

Installed fine here, used the web server. All good.

I am a little confused about the midi side though.

How do I get it to work with two devices, I have a Linnstrument and a Killamix attached and would like to use both at the same time.

you need to give me more details… i cant see your organelle :wink:

what was the exact message?
also as stated in the top post here, i need to see that upgrade_log.txt, without this i cannot help you

as others are not getting the issue I’m increasingly suspecting, its something to do with your USB drive… which we have seen fail in the past . id recommend you back that up , and reformat it.

also what are you using on the mac to unzip the file? try using unarchiver?
what version of macos are you using?

(for reference ive successfully installed this on macs running 10.7, 10.12, 10.13)

Installed. Interestingly it failed when I had it plugged into my HDMI and USB hub. Not sure which one caused the failure. Unplugged everything and gave it another whack and it loaded up just fine.

I LOVE what you’re doing here. I was pretty excited when I saw that you can choose which midi device you want to use.

Here’s what I’ve been banging my head against all day. Tell me to move it if it’s not in the right spot. This is literally the first thing I’ve tried to do with my Organelle. :smiley:

I need to control the Organelle (og) with a QuNexus (qn) and also have the og output midi clk to a Electro Harmonix 45000 looper pedal (lp) so I can keep everything all nice and in sync.

So what I was thinking is that I would connect my trusty powered USB hub to the og and the plug in Roland UM-One Mk2 USB-DIN and the qn and I’d be good to go. No.

Now, made possible by your really awesome beta, I can choose which one will work. and I have different channels for the input qn and the output lp. But I still can’t get them to work at the same time.

Do you think it’s possible for me, with guidance from this lovely community to be able to run an input device (qn) and a separate output device (um1) at the same time?

I’m probably missing something.

oh yes. Happy New Year!

About the multiple devices problem: I got a solution running for my setup, where I need a different device for input as for output. But therefore I needed to switch back to OSS-MIDI, as I can select in the ALSA-MIDI setup dialog only the number of devices, and didn’t understand how I can send MIDI events to the second output.

This are the steps I have done:

  • run /root/scripts/
  • start pd
  • remove the alsa flag in File/Preferences/Startup …
  • select Media/OSS-MIDI and select the correct devices
  • select File/Preferences/Select All Settings …
  • run /root/scripts/

I’m aware that this doesn’t help if you want to run the multiple inputs or outputs at the same time, but maybe it’s a starting point (you can select multiple inputs/outputs in the dialog, I assume that some changes in the mother patch would also allow to use them simultaneous).

I just installed OS 3.1TB Beta without problem. I’m using MacOS10.11.1

No new issues
Thanks man!