Organelle OS 3.1 TB Beta

That did the trick. Now to make a patch that sends start/stop messages! Thank you so much! Time to learn more pd. Thank you thank you!

1 Like

ok, b2 released… two small bug fixes

  • midi in channel OMNI, now works for pgm change and knobs (midi cc)
  •, now is picked up correctly when present in a patch directory

YEP! all seems great! even more added flexibility!!

@thetechnobear do you think you can include Ladspa into the update i have reports it’s having issues [that i anticipated] but i would be grateful if you could include it


@oweno / CG are the ones to decide what should be installed by default on an Organelle.
(idea being its kept slim, and users add what they want, thats why SC is still a separate install)

my personal view, looking at the LADSPA install… (and its only that)

  • we should not be installing ‘plugins’ , onto the OS partition (/usr/lib)
    and for LADSPA this is not needed anyway, as it supports the concept of a path , so like PD externals could be located on the usbdrive/sdcard.
  • anything distributed like this, should be buildable - i.e. a reference to a repo thats compilable…
    (LADSPA is LGPL, so we must respect its license terms, one of which is ensuring access to source, and also license file)
  • ladspa.h is not needed to use a plugin, only to compile.

having said that , I think it would be a good idea (like pd externals) to have a common set of LADSPA available, seems a waste to supply with every patch that needs them.

Just a small request, the desktop on the GUI only has the USB device on it, can a shortcut be created for /sdcard too for future releases?

1 Like

That is a good idea, added to list!

1 Like

Since putting the new os3.1 i’ve been having trouble syncing my arpeggio synth to midi. the lock button doesn’t work consistently. also sometimes the arpeggio synth doesn’t work unless i toggle the select pattern. also the organelle will freeze momentarily sometimes for as long as 10 seconds.

this would be excellent!


Sorry for the late reply… I made a back up of most of the patches, reformated the usb drive then put the patches back on the usb drive and downloaded the udate patch again and ran it. Got the message ‘Upgrage failed: files try downloading and running this patch again’. I’ve added the update log.
Note: I allready used the trial time of Blue harvest :sweat:

Some of the files in the update patch are getting corrupted, probably during the unzipping and copying to USB drive. what computer do you use? if possible can you try on a different machine with different USB drive entirely. Thanks for you patience!

as @oweno says some of the files are getting corrupted

heres an example:

1ceb9a7a063986a62783e89fe984901cbcf8be5a  UpdateOS-3.1b2/extra/pkg/hostapd-2.5-2-armv7h.pkg.tar.xz37a36

548a97cd2a84b89cdf472ae5c3919ff5f00809cc  UpdateOS-3.1b2/extra/pkg/hostapd-2.5-2-armv7h.pkg.tar.xz51d49

the first number represents the ‘signature of the file’,
the first row, is what the file should be, the second is how it appears on your usb stick.

unfortunately, its unclear why this is happening, did you try with a different USB stick?
(sorry, can remember what you tried before)

to end on some positive notes…

  • Blue harvest did actually do its job, probably no consolation, but the errors you are seeing are different from those before.
  • once we get 3.0 onto the machine, this is a thing of the past… because the new installer means you dont unzip things on the computer, so it gets no opportunity to mess them up :wink:

@oweno perhaps a reason to push out a 3.0/3.1 image?

So i’m currently running mac osx 10.11.6. Went to a friend yesterday and used his computer and
usb-drive to put the update on, transferred it to the Organelle and it worked! I then transferred the my patches (backup from hard drive) back to the previous usb-drive that i got with the organelle. I figured with the update the files couldn’t be corrupted. But when i turn on the organelle there seems to be a problem with the patches considering 70% of them are currently not working. Since the 2.1 update i had some difficulties with some patches but not as much as now. I use a lot of copies of the sampler rec patch where i’ve recorded many samples on to but a lot of the samples seem to be distorted or even missing and some i can’t change the speed. A lot of patches just go to a black screen with only the I:…. and O:…… (input and output showing), some have no sound and some patches have an arrow now showing it’s a map but when entered the patch says ‘no patches found’. There are also codes between the patches.
Specifically: QAMP’’240 SAHP’’:17 SAMPLE’’3 SAMP’’!?w SAMT>223
Thanks for helping me out with this i really appreciate it.

sounds like the USB drive has had it.
the original one supplied with the Organelle seems to have limited shelf life.
one ive got also pretty much gave up the ghost.

get yourself a decent brand (SanDisk or similar) and you wont look back, mines not had any issues - and copying too it from the mac/pc is also much faster.
my is similar to the one C&G now ship

Ok, i’m going to the store in a couple of hours i’ll check it out. Thanks

Went to the store and got the usb, transferred the files but the problems i seem to have with the patches are still the same. Should i delete them and download them again to start from scratch?

odd… yeah, what i would do is… delete all patches off the new usbstick, then download one patch, and install that, check its working. then do the rest from the C&G site (new versions all have LINK support :slight_smile: )

i guess if you have been copying the other patches around, then perhaps they were corrupted when you copied off the previous usb stick to your hard drive… all a bit odd though, never heard or seen this before.

Ok beta 3 is here , with some new goodies :wink:

Improved MIDI

With 3.0 we introduced specifying midi devices with alsa device numbers… so your keyboard might be 28:0.
this is ok, but has an issue if you start plugging in multiple controllers, as the order you plug them in, will determine their device numbers
In Beta 3 this changes… now devices are ‘named’, so regardless of order plugged in, or if they are plugged into a usb port, they will still be connected.
so you will now see the config file contains lines like:

aconnect "Ableton Push 2:0" "Pure Data:0"

(rather than aconnect 28:0 128:0)
note: the old format is still compatible.

oh, Ive also removed the annoying ‘press encoder’ after saving a midi setup :wink:

Pedal support

There is a new configuration option for pedal support
Settings->Pedal setup

(tip: this creates a ‘config file’ called, and can be overriden in same way as other files like midi config/mother.pd)

Expression pedals - Expr Min, Expr Max

these specify the range of your expression pedal (min and max)

an example… you plug in your pedal, you find its not quite reaching maximum or minimum on a patch…
if you start PD, you’ll find it never quite goes to 0.0 or 1.0… how to fix, well simply turn up Min until you get 0, and turn down max, until you get 1.0

if you want to be precise a simple pure data patch can tell you the values., simply [r expRaw] -> [print]

this will now print the ‘raw’ values of you pedal , so put it fully up… (mine read 10), now press it fully down (mine rad 830) , set the ExprMin , Expr Max to these values (10, and 830 respectively)

you can also use these value to just reduce travel of the pedal if you wish.

added bonus, if you reverse Min/Max, (e.g. make MIN=1023,MAX=0) , it reverses the ‘polarity’ of the pedal :slight_smile:

Footswitch - Switch Mode

Current Modes:
Patch - is the current behaviour, when the footswitch is pressed, its passed to the patch to interpret
Favourites - when the footswitch is pressed (well actually released), it will switch to the next ‘favourite patch’

This was asked for before, so i implemented
if this is popular Ive a few other ideas in mind ,for other modes:
Sustain, OctaveUp, OctaveDown, Aux, and Freeze.

the idea behind these is is to give some ‘standard behaviour’ to the footswitch rather than leave it up to the patch, which often dont do anything useful (in my experience)

( a patch can select a mode e.g. to put it back in patch mode, send the message /pedal/switchMode 0)


I reinstalled all of the patches and was able to save some of my samples. Everything seems to work fine now! Thanks for all the help :pray:

1 Like

Small bug… or actually a typo: when I go to pedal settings page, the menu displays pedal min instead of max… after changing the max value, it displays correctly as max.

1 Like