Organelle OS 3.1 Update

True!
Never ocurred to me this way around.
Thanks @healthylives !

thanks, fixed now

Here’s to “no Limits” on Organelle :beers::beer::beers: @critter @oweno @thetechnobear and all users

4 Likes

a couple of additional notes, for those not following beta…

installation:
if your already using 3.0 , then just copy the UpgradeOS3.1.zip to the usb stick in patches (do not unzip it), and use the Organelle ‘install…’ option.
this is not only quicker, but is more also reliable.

if your using 2.x, then you will need to unzip, in the same way previous updates have been done.

midi notes

  • midi also now support omni input, and also turning off input/output, and a few other things.
  • midi device selection, now remembers the device rather than the port.
    what does this mean? basically it remembers your device name (e.g. akai 25) rather than which usb port its connected to, so if you move it on a usb hub it will still work.

Can’t wait!
I bought the Organelle to signal process,
Now I’m learning MIDI.
Very awesome :smiley:

I am so happy to hear this!! The beta did not work for me for connecting several midi controllers. I hope the official update will work.

Will there be videos explaining the new OS update and what it can do for idiots like me?

Thanks!

the link is broken again . . .

I just tried it. Worked fine for me. Did you drop the .zip directly into the patches folder, without unzipping it?
Technobear said there’s a chance that could cause an issue. I’m just spit ballin here.

Every time I click on the download link (on the C&G site), I get “this site can’t be reached - thepeacetreaty.org’s server IP address could not be found” . . . can’t get the .zip at all. Downloaded other patches no problem.

Maybe a problem with the computer you’re using? Or a setting?
I can’t imagine it would be the link if it’s working for everyone else.

well, I tried a 3rd computer, and got it - (dunno why the other 2 are jiggered - thnx anyway bomboy!)

Glad you got it worked out man!

Hey thetechnobear, thank you for your work.
I am on macos, and I have this message :
Upgrade failed: files Try downloading and running this patch again

I saw that it was an issue supposed to be fixed on this 3.1 version, but i still have this issue.

Do you have any advice in order to upgrade the organelle on mac ?

Thank you :slight_smile:

@matpot, you got the “Upgrade Failed” message from the Organelle screen?
You might want to try flashing the OS onto the microSD card directly. Instructions here

Hi @chrisk,
Thank you very much for being so reactive, and for all the informations!
Well I don’t have a microSd card adapter at the moment, so I need to find one, but the instructions seems really clear. I will let you know when I manage to make it work. :slight_smile:

Everytime I click the link it just takes me to the patches page, but I can’t find the update. Am I missing something here?

Oh just choose > Patch Categories > OS Update
https://www.critterandguitari.com/tags/os-update

1 Like

Hello, im new here, im trying to update to OS3.1 as the instructions say, but the process never runs. it appears the folder on the oled screen but i click it and nothing happens.
im using os2.1 right now, any help will be welcomed.
thanks

What happens when you select the update patch? do you see any activity on the Organelle screen, or is it totally blank? You could try downloading the update patch again, and copying to the USB drive. if possible use a different USB drive (or reformat it)

got the same problem as a new organelle owner. i solved it for me:
as i unziped the file, my Pc created a folder called “UpdateOS-3.1”. I copied that to the usb patch folder, started organelle, tried to load the UpdateOS-3.1 patch, but nothung happend… th trick:

My PC created another folder with the name “UpdateOS-3.1” within the “UpdateOS-3.1” folder… thats the problem.
check if the path is X://patches/UpdateOS-3.1/* * files * *
and NOT X://patches/UpdateOS-3.1/UpdateOS-3.1/* * files * *