OS 3.1 and Orac Help

Update:
I tried using Wifi to upload and install the orac.zop patch. It uploaded fine. I refreshed to update the Organelle. But install failed in the same way it did via USB Stick. See pics attached.

Interesting notes:
I uploaded and installed other .zip patches just fine. However I noticed that whenever I tried a .zop it fails in the same way it did with the orac.zop.
So I tried changing orac.zop to orac.zip just to see what would happen, and it actually installed! But then I found that the patch wasn’t working properly (missing functions, etc).
Does this have anything to do with .zop files? Did I possibly get a faulty Organelle? I’m not a genius engineer or anything, but I’m also not techno-illiterate. I thought I’d be able to figure this out by now, which is what’s so frustrating! I really hope there’s a solution other than returning this beauty of an instrument. Anyone have any thoughts?
Thanks everyone for the support!

That does sound frustrating! Can you attach the orac.zop file that you are using?

Maybe worth trying SD card storage and ditching USB drive (wasn’t clear if you did this, or were just using wifi to upload it to the usb stick). Possible something wrong w USB drive?

@oweno Sorry but the forum won’t let me upload the orac.zop file due to file type restrictions. Here’s a link to where I got it though https://patchstorage.com/orac-2-0-for-organelle/
It’s straight from the source on Patch Storage, and I’ve re-downloaded and attempted multiple times with new downloads to make sure it wasn’t a corrupt file.

@TheDeadFarmer I was thinking the same thing, that there was something wrong with the USB drive. But I tried using the SD card method too, via WiFi upload. Still no luck. :frowning:

Is it at all possible that the Organelle itself is faulty somehow? I doubt it but just thought I’d ask your opinion.

Thanks for the comments and support!

It seems unlikely a hardware problem since the machine is turning on, booting up and running software, etc… Did you install anything else on it, patches or otherwise? It might be something wrong with the disk image on the SD card. To truly bring the Organelle to ‘factory reset’, you could burn a new OS image on the SD card. If you want to try, follow steps in Chapter 7.1 of the manual:

https://www.critterandguitari.com/manual?m=Organelle_M_Manual#71-burning-sd-card-disk-image

If it is still not working, I’d say we should take a look, please contact us.

hmm, puzzling…

so Ive just download orac.zop and installed on my organellem without issue…
so its not corrupted on patchstorage.

when you renamed to orac.zip, you transferred this to the organelle, and did install?

this is even more puzzling, something very odd is happening…because
zip and zop files are treated identically when they are installed on the organelle.
(both get ‘installed’ via the install_packages.sh)
so… if zop fails, so should zip - also if you just renamed it to zip, then orac should have installed correctly

(the only thing that would not install correctly, is if you unzip the files on your desktop and then transfer them to the organelle … this wont work, since it wont call the deploy script)


hmm, so whats going on?

the only ‘weird’ thing, Ive heard of in this area is on Windows.
some people have said that windows when it downloads it, it automatically unpacks it. ( I think there is a way to stop this?!) - so they then have tried to zip it up again.
if you did this, then I could see that causing issues perhaps…

as a test, Ive put a copy of orac.zop on my dropbox, try downloading it from there, perhaps windows will leave it ‘intact’ and it’ll then work

Yes I’ve tried downloading/installing a new orac.zop file multiple times, and I tried over Wifi too. :frowning:

I’ll try these things again today to be thorough, but I’m doubtful it’ll work since I’ve already gone through these steps.

Arigato!

@technobear Thanks for the support!

I’m using a Mac. Haven’t had issues with it unzipping upon download.

When I renamed from zop to zip and Wifi transferred to the Organelle, it did install but it seemed like the patch was malfunctioning. (For example, I couldn’t access the modules. I was stuck in the first module)

Thanks for the link to orac via your dropbox! I’ll try that today and report my findings.

Sorry for all the trouble, and many thanks for the support.

Hmm have to say I’m at a loss then, :frowning:
Ive installed orac countless times from the zop , even during dev this is how I do it and always without issues.

I think I’d do as @oweno suggested and reinstall the image - as I cannot think what else could be wrong.