Preventing Midi out


#1

Hello

I’m trying to prevent the keys of the organelle from sending Midi data back through the usb cable.

I have tried disabling Midi out in the Midi settings and switching up the midi channels, however some patches (I guess) still allows the keys to send Midi data, which then affects the rest of my rig.

I use an arturia beatstep as a hub, and I just wanna keep the organelle on the midi clock without sending note information.
Any idea as to where I am going wrong? : )

//S


#2

Assuming os 3.1. …
The midi out disable can only disable the midi sent out as default by the mother host.
But it’s always possible for the patch to send out midi too ( this is desirable) , so you’d have to check the patch.
(patches could be written to respect the midi out disable flag , but mostly they are not).


#3

Os 3.1 , yes.

Right, looking at the mother.pd of the patch there are a ton of midi I/o control values. Any suggestions for how I could turn off “key press midi notes out” from there?


#4

The ones in mother.pd are already disabled, by the midi settings - it’s the ones in the patches that are possibly the issue.

Which patch are you having an issue with?

( on my side , I think I have a small issue with Orac , which I need to retest and fix for 1.1)


#5

Ah ok : )
I’m working with the “arpeggio synth” patch for this!

//S


#6

@Soulpolka In the Arpeggio Synth patch sends the arpeggios out on MIDI Ch. 2. In the ‘Arp’ subpatch you can delete this:

07%20AM


#7

Awesome!
That is exactly the command i was looking for…

So basically I can delete “noteout” in any given patch that I dont want sending midi info and achieve the same result?

Thank you