Problem updating software on 5 Moons


I received my brand 5 Moons today. Before starting I followed the Stereo Update procedure on this forum. I then plugged in the 5 Moons via a USB power socket and tried to start using it. I can only get a very quiet sound passing through it. I’ve checked my chain and all the other cables and machines, the issue is definitely with the 5 Moons.

I when I switch it on, all the lights flash red through white a couple of times, then remain white. Pressing one of the record enable buttons doesn’t seem to activate the track for recording as per the video. In fact none of the buttons seem to have any effect aside from the power button.

I tried two different USB power sockets, and two different cables, but it didn’t make any difference.

I hope someone can help, I was hoping to use this this weekend.


Thank you for getting a 5 Moons!

Did you turn on the monitor? Button C toggles the monitor on/off.

Can you post a screenshot of the contents of the ‘pd’ folder?


Yes I tried the monitor button, it didn’t make a difference.

I just tried deleting the new “PD” folder and replacing it with the old one that was already there (ie pre stereo update) and it seems to work now. So it must have been an issue with the stereo firmware installation. I’;m going to try installing it again, hang on…

Ok so I tried adding the stereo firmware again and the same thing happened. The only part where it differs from the instructions is when it comes to ejecting. I eject the drive on my PC and hold down the 5 buttons, but instead of the lights being white, they are either red, blue, or green - it varies depending on when I press the buttons.

I’ll get you a screenshot of the folder, just a sec

This is good to hear. Thanks for trying that.

Can you delete the files of the stereo pd folder so that the entire contents are as follows:

Ok I tried that. It’s still exactly the same. I eject from the PC via the browser, press all five buttons in the same way that I did to enter disk mode, but the buttons all turn red rather than white (as they do with the original mono pd folder). And as before, it doesn’t work, none of the buttons work and no sound passes through.

Can you check the ‘lib’ folder and remove any extraneous files that begin with a ‘.’ ?

Since the original OS works, it would suggest that the 5 Moons doesn’t like something about how the stereo update was unzipped on the Windows OS - those extra files should not be there.

OK just tried that, still the same. How about the folder called “_MACOSX” ?

There’s a couple of files starting with “.” in there too

Yes, please delete the _MACOSX folder.

Ok tried that, made no difference. I also tried deleting the pd-mono folder but it’s still the same

There’s basically nothing a “,” in front of the name now, not even in the Songs folder.

Joining in just to say I’m having the same odd issue since updating.

  • on power up the LEDs cycle from pink to white 3 times and then remain white.

  • I can barely hear the audio in signal and it doesn’t change in loudness whether I press the monitor button or manually turn the volume pot.

  • unit is completely unresponsive otherwise.

  • one other thing is if I put it into disk mode all of the sudden the volume jumps to what I assume is 100%. It scared the pants off of me!

I’m traveling and so have been unable to try reloading the firmware from my computer but will jump on it when I get home on the 21st of November.

Edit: one more thing I did in case this has some effect on it is I deleted everything in my Songs folder, assuming that the unit would create folder 1 when I powered it up and created a new song. So my Songs folder is completely empty.

Ah I’m glad it’s not just me! I didn’t do anything to my songs folder. Are you saying that deleting the Songs folder made it work as expected, with the stereo firmware?

Hey there! Yeah I was actually relieved in a way to find this topic. It’s nice knowing I’m not alone! :smiley:

And no, it’s still not working. I just threw that last bit of info in there in case that would give the C&G gang a bit more info about what’s going on.

I wish I had my laptop with me while traveling so I could troubleshoot, but considering you said you didn’t touch your Songs folder I’m guessing that bit of info doesn’t have anything to do with this issue.

Are you also using a Windows computer to update your 5 Moons?

I am, yes. I’m running Windows 11.

Yeah I’m on 11 too, I’ve tried it across two different machines.

I was able to try it out on a Windows 10 machine, and despite some initial trouble I got it working.

The .zip file extracts to a folder named pd and inside there is the another folder pd (the one that should be copied to 5Moons). I copied the parent pd folder and I got the same freezing behavior you describe @sjbucks… but from your screenshot, your folder structure looks fine. I moved or deleted and then copied it correctly and after ejecting and exiting disk mode this time I ran into the same behavior, so I thought I might be onto something.

So I started from the beginning, but then it just worked, and has been working several other times as well (even starting from freshly flashed SD card)… so there might be something going on with Windows and the files, but hard to know. I’ll try it some more today.

The computer is asking me to update to Windows 11 so maybe it is a good time.

(also edited topic title for clarity)

This is great to hear!

Forgive me as I’m a bit dense at times and also currently traveling, but it sounds like I should simply give the firmware update another shot?

P.S. I just realized I may have unzipped the .zip file on my desktop and copied the files over instead of doing the unzip on the card itself. I wonder if that made any kind of difference, although I can’t imagine why that would happen.

Hey there! Just wanted to check back in here…finally got back into town and sort of started from square one and everything’s working fine now.

I actually just deleted everything off the card in disk mode and then re-copied the pd folder over to it. This seemed to make my 5 Moons happy, but that caused another error in that I couldn’t actually record any songs.

To fix this I simply created a new “songs” folder in the root directory and now everything seems to be fully happy with my 5 Moons.

Hope everybody else is up and working now too.

For the record, I did this on my Windows 11 machine and this time around had no issues. I also did NOT copy over the “_MACOS” folder…only the “pd” folder.


1 Like