Testing Self-made TRS-MIDI cable with Organelle M

I’m new to organelle, just got an organelle M. I want to tempo synch via midi (got a midi clock comming into the TRS midi input). I made up the cable myself (MIDI to TRS type A) but nothing seems to be happening. Does anyone know a standard test (e.g. name of patch that def responds to midi clock sync) so I can work out if its cable or something else.

Many thanks

Some straightforward patches with a BPM aspect to try: Arpeggio Synth, Pow Pow Polybeats, Euclidean Rhythms, Sampler Style.

Any C&G patch with a BPM control will work. If a C&G patch doesn’t have a BPM element, the patch will not utilize MIDI Clock if it is present.

Thanks, that’s great. Still no midi clock from TRS midi socket but I tried USB midi as a test and that works With the patches you suggested.

Cable tests are good so not sure why can’t get clock via trs. Anyone out there done this with orgM?

Any tips/tricks? I selected midi in on midi setup page but nothing, plug in usb midi and select usb midi on setup and clock is good.

Just confirmed that MIDI clock syncs both in and out via the TRS ports using my home made cables. It’s not the most stable clock coming in, but it works. I haven’t adjusted any settings. Maybe double check your cables? Let me know if I can verify anything for you. :slight_smile:

Thanks fwwm, I made up a new cable (despite the previous one testing good for continuity) and now i have midi sync, of sorts. Its very unstable. I set clock in to be 100bpm and the organelle drifts between 99 and 120bpm. I set it to 120bpm and it drifts between 119 ans 144bpm. This is all in the metronome patch.

Switch to arpeggio synth and things go bonkers will wildly unstable bpm varying accross a range of thousands.

Then unplug the midi cable and still arpeggio synth wildly oscillating. Only way i have found to get back to “normal” is pluf USB midi in, change settings to pick that up and then unplug it. Back to stability.

Does this sound like what you see fwwn?

I should add with USB midi sync everything is stable to +/- 1bpm (still not great but managable) perhaps chrisk (who works at G+C?) can tell us more about stability of midi link? In summary:

USB midi - usable. but stability +/1 1bpm
TRS midi - unusable, best stability is random range of about +20bpm-10bpm, worst case is completly random.

IS this a bug or do i have a defective orgM? (all tests above done with simplest setup - octatrack midi sync out direct to org TRS midi in)

There is a bug in the MIDI Setup which you might be experiencing, and this is the correct fix. The MIDI device that shows up in MIDI Setup when no USB devices are plugged in (Midi Through Port-0) should not be in there (this is the bug), it should really just say ‘None’ or ‘None connected’ or whatever. If you select it (and unfortunately you don’t have a choice not to once you press ‘MIDI Device’), there is a loop created from the input of the patch to the output. In many patches MIDI clock gets passed through, so a feedback loop begins and tempo goes wild. The fix is to select a different MIDI device, but you have to have one to plug in. (there is also another fix, you can edit or remove the patch_loaded.sh file on the root level of USB or SD card). This might explain the problems on TRS MIDI.

MIDI clock is a steady stream of messages, 24 of them per quarter note. While these messages may drift a little, overall the clock will stay synchronized with the master, as long as none of the messages are actually dropped. The deviation you are seeing in tempo is most likely a display issue, i.e. rounding error. For example the master is sending clock at 100.7 BPM, one slave might round down and display 100, another might say 101, but if they are receiving all the clock messages and using those messages to drive sequencers or arpeggiators, everything should remain in sync.

1 Like

Nope, my MIDI sync does fluctuate over the TRS ports, but only by 1 or 2 BPM, which seems to be just a display issue after reading @oweno’s explanation. Are your cables shielded? Maybe measure the resistance over the cable, even if it tests good for continuity? Not sure what else it could be. :frowning:

OK, so the bug described by oweno is partly what I am seeing, hopefully thats in line for a fix on the next update?

Thanks for testing fwwwn, my cable is shielded, its all a bit odd, I make up my own midi cables for everything (so I can have precise custom lengths) and not had this problem before. The TRS jacks are new though (and a bit cheap) so its just about possible that’s a problem. I have ordered a jack to din adaptor and will see if that works when it arrives, in the mean time I’ll stick to USB midi sync.

Thanks for all your help and will update if I make any progress.

Update here changed thread as the topic has moved on from cable issues.