MIDI on the Organelle M - the jack doesnt seem to work mostly, USB does

Hi,

this topic started with me thinking I had a bad MIDI cable ( thread here )

But my conclusion after testing 3 cables and 2 different din to jack adapters is that this is not to do with cables.

If I connect my octatrack via USB midi direct to the organelle (using one ofthese) then I have good clock stability on organelle and complete MIDI control. I can sequence organelle from OT, no problems.

If I swap out USB for MIDI to Midi Jack cable then I get sometimes a good clock, sometimes an unstable clock (there is an acknowledged bug relating to the clock that @oweno described in the thread above) however, in addition I can’t sequence the organelle from the OT, every trigger (key press) sent stays locked so I get a build up of sound. This is the same across multiple patches.

It seems that maybe the MIDI (being a new feature on the M) is in need of some bug fixes? I’ll wait in anticipation for that. In the mean time midi in over jack to din is unusable so I will have to stick to USB, annoying, as I’d like to use the USB port for other things (storage), but not the end of the world.

Of course it could be I have a defective organelle M? Would really appreciate it if anyone else out their can let me know their experiences with midi jack in control to put my mind at rest or not!.

Best Wishes

Which jack to din adapter are you using?

This one.

Along with a second type a adapter and several din to jack custom made cables.

It is strange that the Organelle would receive every Note ‘On’ message but miss every ‘off’ (vel = 0) (unless your Octatrack never sends a note with velocity of 0 so Organelle never turns off the note). Can you try swapping arrangement so Organelle is sending MIDI notes/clock to your Octatrack?

Like I’ve mentioned in the previous thread, my Organelle seems to be working perfectly using the rear MIDI connections, both in and out. No stuck notes. Clock seems to jitter a few BPM but nothing major. I know that doesn’t help your case, but I’m starting to suspect either hardware failure, or the devices that you’re using to send MIDI to the Organelle are misconfigured or misbehaving. :frowning:

Hi, thanks @fwwwn, our previous discussion was regarding the clock only, I didnt realise you had also fully midi sequenced via the midi jack. Given that I am using exactly the same config for USB midi (which all works) and jack midi (which doesnt) I cant see how it can be the devices controlling that are at fault, I’m now veering towards having a faulty midi in socket, which is a real pain. I’ll contact my supplier for a replacement.

thanks @chrisk , thats a bit complicated to do so will have to wait till later but I have just checked midi out of organelle into moog mother 32 and that all works fine (note on/off as expected) will try controlling OT later but thats not a “known” config for me so not sure what to expect. Normally I control/sequence everything from the OT and the organelle is the only beastie to have given me grief like this, however, I forgive it for being just the best thing in all other respects!

Update: just tried controlling OT from organelle, top range of org keyboard plays notes on/off as expected on OT so all seems good. Bottom half seem to map to controls rather than notes, this is almost certainly my inexperience in set up of this config , will look deeper later but so far seems ok? If midi out is ok but midi in not what does this mean @chrisk ?

Thanks for going deep on this.
Do you have another synth you can try sending MIDI to the Organelle with?

No, only other devices are midi over USB from which all works fine. At this point i’m about 90% confident it’s a hardware fault so i’ve Returned to my supplier for a replacement. No one else on here has reported similar issues so hopefully it’s just a one off bad connection. I’ll update when I get my replacement to confirm.

I should add @chrisk that I shared your puzzlement about missing every note off and getting every note on, that didn’t sound like hardware fault so I messed with this some more and actually it misses some note on signals as well, this swung it for me to hardware.

Thanks for your help everyone.

hey i am having a strange midi situation as well. when i have no other usb stick loaded to the M, and the OS is just running from the SD card the MIDI bpm goes absolutely crazy and runs all the way up to like 2000 or something insane. in fact the numbers just keep changing and any note i play gets frozen. i dont have this problem however if i am controlling the midi through usb, or if i am running patches from a stick instead of the sd card. what could be the issue yall think?

@watrshed Sorry about this issue. It is a recently discovered bug that we will fix with an OS update. The cause of this is in MIDI settings, where you can select ‘MIDI Through Port 0’ which connects MIDI Out to In in software. This loop causes the ramping tempo. (If you are curious the bug is that the ‘MIDI Through Port 0’ should have never been in the device list to begin with. It is not ‘MIDI Thru’ in the traditional sense, e.g. MIDI input being passed to the output, but it is actually connecting internally the output from the software (Pd) to the input, causing a feedback loop…)

For now, please avoid selecting ‘MIDI Through Port 0’ and you should be fine. If you do select by mistake, the simple fix is to insert any USB MIDI controller, navigate to the MIDI device and select that controller instead.

1 Like

Hi @watrshed yes, @chrisk explained this bug to me earlier here and I see he has beaten me to it replying to your post. The bug is fustrating when you dont know whats going on but its easy to avoid when you do know. My problems seemed to be hardware related, confused initially by this bug, I’m waiting for a new organelle and will update here when it arrives.

thanks for the reply @chrisk. i just stick to the usb midi controller. i did think that option for midi thru port=0 was strange, as you said it didnt make sense. i love my M though and was hoping it was a common bug. best.
also @Devoid, i hope you get your M back asap as i can imagine you are missing it!
cheers

1 Like

@chrisk Does this mean that in the future, you will be able to route midi through the Organelle M? So, if you have a USB midi controller on one USB port and a synth on the second USB port, you could route Midi from the controller through the Organelle (as a midi hub) to the synth?

This kind routing is already possible, but you have to set it up manually, there is no menu options for it yet. More info here: