WiFi Setup with 4.0

Updated to F 4.0 successfully (it seems)
Can’t get WiFi working … following manual …
I can get the AP mode connected (no password requested) by switching on AP mode on the Organelle, selecting “Connect” to Organelle in the WiFi networks detected (no password requested), and find the web server in my browser (Chrome).
But the PC shows Organelle with “No internet access”
I have downloaded Orac to my PC, uploaded it using the Patch Manager, and have installed it apparently OK on the Organelle … so the AP mode works.
The WiFi Setup page opens up as expected in the manual, with a “music” network … and this is shown on the Organelle
Clicking on it, the “Connecting…” cycles and the stops with “Problem Connecting”, and I have lost AP mode and start all over again.
What might be up?
Do I need a proper WiFi or will AP be all I need?
Cheers
Toby

Hi,

It seems like the WiFi is working as it should.

RE: Access Point (AP) Method:
If you have successfully loaded Orac onto the Organelle with the AP method (‘Organelle’ network) using the Web Interface’s Patch Manager, it is working. With AP method, the Organelle creates its own network and your PC joins this network. The Access Point does not connect to internet. If your PC is somehow checking to see if a network is further connected to the ‘internet’ the message from your PC is accurate.

RE: ‘Music’ Network:
The ‘Music’ network is a stored network name (SSID) that we use for testing the WiFi capability. You are getting the ‘Problem Connecting’ message because the Organelle cannot find that specific network in your location (this is expected). You can ignore it or delete this network in the ‘WiFi Setup’ page of Web Interface. If you want to add existing networks to the list of stored networks please follow the steps here: https://www.critterandguitari.com/manual?m=Organelle_M_Manual#53-joining-existing-wifi-network. Please remember that the C&G provided USB-WiFi adapter only works with 2.4GHz networks.


Connecting via AP and Store WiFi Network are mutually exclusive - the Organelle is using the USB-WiFi adapter to either create its own network (AP) or to connect to an existing network. So if you start AP, then select a stored network, the AP will be shut off (regardless of the stored network being present in your current location or not).


Either method is fine - its up to you.

Thank you … the achieving the AP setup I understood to be a temporary mode on the way to a “proper” connection … which I couldn’t seem to add successfully following para 5.3: I had added it on the web page, but didn’t see it on the Organelle. I then discovered that by going back to the Home page and re-selecting WiFi Setup the added SSID appeared and all works fine.
Most importantly, I hadn’t properly read the first sentence of 5.3 … and understood your last line “Either method is fine”
Brilliant!

Hey bumping this thread because i cant connect to wifi either after update
thanks!. i can get through via AP no problem but cannot connect to wifi. ive double checked passwords being correct multiple times. dont know what else to do. get a problem connecting message everytime. i am on an M.
Thanks

if it was a dongle issue i wouldnt be able to connect to access point right?

Hi @watrshed
You’re able to connect your computer to the Organelle’s AP, right? If so, the USB-WiFi adapter is working.

Once on the AP, have you entered your existing WiFi network’s name & password through the Web Interface? Follow sections 5.2 & 5.3 in the manual: https://www.critterandguitari.com/manual?m=Organelle_M_Manual#52-web-interface

1 Like

Yeah ive done all of that and still having trouble connecting. This is a new issue im having ever since the update. Before the update I was able to connect fine, no problem. So im confused as to what Im missing or what has changed.

If AP mode is working and WiFi is not, then it’s down to your WiFi router settings.

The odd thing is this has not changed in the update - so very unclear why it would have worked but not now.
Perhaps something on router has also changed?

Could be a number of things:
( other than just name/password)

  • incompatible security settings.
  • not supplying dhcp

Unfortunately only way I can think of perhaps getting more info is to look at router logs, or perhaps bring WiFi up on command line of organelle.

( if you have a spare card it be interesting to know if you use the old organelle image if it works against!)

This is an odd scenario. None of my other devices have any problem latching to the signal either. I will take a closer look at the router issue. Thanks for reply Mark! hope you are well

1 Like

Hello,

Digging up this topic, as I had an identical issue with a freshly flashed SD card and OS 4.0 on my Organelle M.
AP was working fine, but I couldn’t connect to any other WiFi networks. I tried a lot of things, re-flashing, testing the USB WiFi adapter etc.
But then I realized that the permissions on the /sdcard partition were different from a backup Organelle SD card I have. So i tried changing them and that fixed it straight away.

here is the command I used to change the permissions:

sudo chmod -R 777 /sdcard

I hope it’s fine to have this partition read/write for everyone, but since that change, everything’s been working perfectly.