CRC Error with Organelle 4.0 firmware

I am getting CRC errors when trying to unzip the new 4.0 firmware for my v1 Organelle. Any suggestions where I can get an non-corrupt copy?

Hi - what platform & unzip program are you on? We recommend the programs in step #2 here:

I am on a Windows 10 desktop, using 7-Zip. I have tried also using my laptop (also Win10), but no fix. I also tried redownloading from my laptop and using the Windows unzip dialog. Nothing is working. In every case I get a CRC error right at the end of the unzipping process.

What happens if you try skipping step 2 and burning an unzipped image with Etcher? We haven’t had much luck with flashing unzipped images on Macs, but it could be worth a shot on Windows.

I don’t think the image is corrupted since we’ve heard from others that it is working (at least with MacOS).

There’s something “not quite right” with the image, since Etcher won’t flash it when it’s zipped. Or rather, it flashes it, then fails verification. This is suspicious to me, since other things I’ve tried, such as Raspberry Pi images, flash from zipped.

Unzipping the file (on Mac OS Catalina) does allow Etcher to work. So it’s not a totally knackered file, just doesn’t match what Etcher can work with whilst compressed.

[edit: replaced Balena with Etcher since it makes more sense]

Etcher errors out trying to burn with the zip file; I tried both downloads, but both threw CRC errors. Is there any way to download a different copy? I’ve tried different machines, different extractors, the only thing I have not been able to try is a different source file.

FYI, I used the same files with the same downloads on my wife’s Mac and everything updated perfectly fine. No idea why Windows failed.

Thanks for the update! We’re taking a look at how the image is compressed and what Windows is looking for.

First off I want to say I am happy to be a part of the Organelle family again after having to sell my original unit due to unforeseen circumstances.

Just got my Organelle-M and wanted to update the firmware to 4.0 before uploading any patches. After getting the zip file I tried unzipping with 7 Zip and get the same CRC error. Also tried with my Windows 10 unzip tool and receive an error as well.

Any way to get around this?

You could try flashing the newly posted unzipped OS files:

Thanks @chrisk! Got it to work!

Could someone please re-create and re-upload the zipped images for Organelle 1 and M?
At the moment, unzipping the image results in:

unzip -v 
Length   Method    Size  Cmpr    Date    Time   CRC-32   Name
--------  ------  ------- ---- ---------- ----- --------  ----
3653238784  Defl:N 2047421589  44% 02-12-2020 13:16 d2e5ce46  OG1-v4.0.img
--------          -------  ---                            -------
3653238784         2047421589  44%                            1 file

testing: OG1-v4.0.img             OK
No errors detected in compressed data of