Organelle OS version 4.0

I am getting a crc error every time I try to unzip the file using 7zip on windows. Tried unzipping with whatever windows tool and same result. How did you go about fixing? Just got my new organelle-m today and was quite bummed after that issue.

Hello friend! Here is what I did:

  1. Upload the .zip file here: https://extract.me/ to extract the .zip file
  2. Download the .img file to your computer and then use Etcher to flash it. The .img file should be 7.9GB in size.

Once you follow those steps it should work without a problem!

If you look at my post below in response to SharpSharries, you can see what I did to fix this issue. For some reason the posting system didn’t let me re post the steps in a response to you.

Thanks @raflance,
I already tried this but it takes ages to upload 2GB and download 3,5GB (for organelle 1)

The upload get stuck several times… I don’t know why.

I think I will stay with OS 3 for now or sell my organelle because of frustration. I spend most of the time with organelle trying to figure something out because something is behaving strange… instead of playing music with it.

I’m happy to send you a link to the unzipped .img file :slight_smile:

We uploaded unzipped versions of the disk images. These files are much larger (about 7.95 GB) so they will take longer to download, but won’t need to be unzipped.

Organelle 1
http://thepeacetreaty.org/organelle/diskimages/OG1-v4.0.img

Organelle M
http://thepeacetreaty.org/organellem/images/OGM-v4.0.img

1 Like

Thanks @raflance! That did the trick. Took a while to unzip but it worked in the end

Yay! Thank you!!

Awesome. So glad it worked! It was tricky for me to figure out but I’m glad that it could help others too.

Thanks a lot
I will try tomorrow…

:slight_smile:

Hey gang, I just tried flashing the OS 4 image. Couldn’t get it to unzip with 7zip in windows 10. It gave CRC error. Downloaded the unzipped version and it flashed with balena etcher but would not boot. Was finally able to get the zipped version to unzip with WinRar. Trying to flash it again now. I’ll let you know how it goes. If it doesn’t work I’ll have to roll back I guess. I’ve seldom had this much trouble flashing an OS image to a disk. :frowning: I’m using the SD card that came with my Organelle M.

Hey @Christopher. I had the same issue trying to unzip the file and getting the CRC error. I followed the steps from @raflance posted above and that worked for me to unzip. Took a while and even had an error but I was able to resume and the downloaded just started right back up where it left off. After that I had no problem with etcher. Hope you get it to work out for you.

I’m on my third go with this method. First time it just froze at 100% and stayed there for quite a long time but maybe I didn’t wait long enough? Second time the upload failed. Now on my third time uploading. Fingers crossed!

it’s been over an hour now and extract.me is still frozen at 100%… I’m going to give it another 30 mins or so but I think this is a lost cause.

I tried extracting the zip file again, this time with WinZip and got the following error:

The size of the extracted file (7948206080) does not match the uncompressed size (3653238784) recorded in the Zip file.
Severe Error: File size doesn’t match uncompressed size.

Update: Apologies… this is my final ‘report’ on this. I guess I’m hoping that sharing this might help narrow down what the issue is?

CRC failed on the 3.2 zipped image img as well…I tried win32 Disk Imager with the uncompressed 4.0 image and it also says it wrote successfully but the Organelle won’t boot. Didn’t back anything up (not smart). Now it’s useless.

Hey @Christopher. I used a new 32 Gb card to flash the new firmware. Was all I had laying around and didn’t want to use the stock card for the same reason you are experiencing. Maybe try a new sd card? Extract.me did take a while to unzip the file. It failed for me once and I was able to click on the download and resume right where it left off. I would keep letting it go when it hits 100%. Don’t remember how long it took exactly but I would say at least an hour to unzip.

tried a bigger SD card with the uncompressed images @oweno provided. Still no love. Tried again with extract.me… it’s been 3 hours now. I’m giving up. I’ve spent all day trying to fix this. I’ll see if I can try on a friends mac but I really just wish I hadn’t started this process…

so I am back now.
could you post the link here or send it?
Thanks!

when I downloaded the zipped OG1-V4.0 version: after extracting it was only 3,4GB
But now your unzipped version is 7,4GB for both organelles.
Was this the error?

It’s actually closer to 7.95 GB

unzipping OG1-V4.0.img.zip should give you a file 7.95 GB in size. How are you extracting it?

Are you using WinZip? Sounds similar to the problem @Christopher was having

I’ll try to figure out what is wrong with the zipped versions. In the meantime, are you able to download and burn the unzipped versions?

@oweno: I used 7-zip and win-zip and had the same problems.
But right now I am downloading the uncompressed file which takes
hours…
I will be back for reporting!