DX7 for Organelle

I’ve just updated to OS4.0 and wanted to try out the DX7 emulation from super collider.
However it’s being sneaky and won’t work. After putting the zip file in patches and instaling it two files appear (dx7.afx and dx7.sfc) and I’ve put them in their own file (DX7.sc) however it says no presets available.

I’ve tried technobears simple poly on super collider but found that also does not work / produce a sound.

Is super collider working on OS4 or is there something I need to do to get it to work?

Alternativey I tried Shreeswiftys OX7 but sadly this also does not make a sound, yet all of the presets are present which is super sad as it looks mighty incredible.

Anyone got any thoughts?

hmm, i’ll have to give it a go… I’ll admit I just launched SC to see it was there, I didn’t test it,
perhaps its missing some configuration?
on my simply poly, is the display coming up on the oled? pots working?

also are you using an organelle-m or organelle-1?

can you also point me to the original dx7 emulator you tried.

Hey hey,
I’m using the Organelle-M
On the simply poly the only things visible on my OLED is the Input / Output and battery. The pots don’t do anything sadly. Tried full turns and using the aux just in case.

As for the DX7 emulator it was on patchstorage

I wish I could be more useful with understanding code to try help in some way.

ok, Ive tested here…

organelle-1 is working fine… (you knew i was going to stay that didnt you ;))

the organelle-m install has a few issues
its got supercollider installed in a different place to the organelle-1, and its missing jack.
these can be fixed, by entering the following on the command line (of organelle)

sudo ~/scripts/remount-rw.sh;sudo ln -s /usr/bin/sclang /usr/local/bin/;sudo ~/scripts/remount-ro.sh 
sudo ~/scripts/remount-rw.sh; sudo apt-get install jackd; sudo ~/scripts/remount-ro.sh

this gets supercollider working, and fired up from menu correctly…

but then Im seeing the following error:

music@organellem:/tmp/patch $ compiling class library...
QXcbConnection: Could not connect to display 

I need to see if i can find a way around this, I thought -D would prevent this - but it doesn’t,
and Ive a nasty feeling when I compiled Supercollider for organelle-1 I used some extra compiler flags to prevent it requiring an X display… so i need to go review that too :frowning:

1 Like

Hahah, it had to be. It’s all good though, I’m super excited that you found out what was causing the issue so quickly :slight_smile:

No need to rush it, you do way more than enough for everyone here. So whenever you get the chance to review it and send feedback is more than enough for me. Thanks again for the speed coding.

k, yeah… the issue is we need Supercollider compiled without QT support, otherwise it requires a display

there is a workaround by install xvfb (a virtual ‘screen’), and then running this in the background
e.g.

sudo apt-get install xvfb
export DISPLAY=:0
Xvfb :0 -ac -screen 0 1280x1024x16 &

the last 2 lines need to be run before any SC patch

but really this is not the preferred route, really we should build supercollider with QT off.