"Failed to symlink" messages on Eyesy restart

I’ve been using the web interface over AP to make mode edits and add new sketches. I always need to stop/start video from the web interface in order to see changes. Just saving and reloading a mode doesn’t seem to make the changes immediately available.

Everything is working fine as far as I can tell, but I did happen to see a couple error message scroll by quickly on restart:

starting...
Failed to symlink /root/.config/pulse/6d2eba5f8339454faac41f67778768b0-runtime.tmp to /tmp/pulse-PKdhtXMmr18n: Read-only file system
Failed to symlink /root/.config/pulse/6d2eba5f8339454faac41f67778768b0-runtime.tmp: Read-only file system
pygame version 1.9.3
opening frame buffer...
opened screen at: (1280, 720)

These errors seem to have been discussed back in 2018 in regard to the ETC, but I don’t know what that means for the Eyesy, or if this is normal. I am running the 2.0 firmware and won’t be able to test on 2.1 for a week or so.

Anyone else seeing this? And explanations?

I haven’t seen those errors, but I have run into trouble stopping / starting the python video many times. Sometimes it would crap out and I’d need to reboot.

It is true that saving does not reload the mode (although I think this might be changed on 2.1, I don’t have it in front of me). But funny you are not seeing the changes even after pressing reload since this should be reloading the module and running setup(), etc. Does it say ‘reloaded’ on the web console when you hit reload? Another thing you have to be careful about is that the EYESY is playing the mode you are editing, it is easy to be watching one mode while you are editing another.

@oweno I retested and can now see that if I have the patch I am editing loaded in the editor as well as outputting from Eyesy, I can make changes, Save, and Reload and see those changes (like changing the size of a circle).

If I have Mode 1 active (outputting from Eyesy) and try drilling down to Mode 2 to edit, that’s where I need to do a restart to really see the changes. I can’t just use the arrow keys to go back to the mode I edited to see the changes. I have to either go back to Mode 1 and hit reload or restart the Eyesy.

I think it’s the behavior of the arrow keys that is less intuitive here, but now it makes sense. I was doing a lot of swapping in between modes, comparing code, so I probably didn’t make Eyesy too happy.

Will still be curious how 2.1 responds when I am able to test.

I got a spare SD card and did the 2.1 OS update per the easy instructions in the manual. No issues with that part.

However, here’s what I found:

  1. There’s still not a “2.1” label on startup anywhere on the screen. So perhaps the 2.1 download image isn’t the right file??
  2. The WIFI issues are not fixed when trying to connect to a 2.4 Ghz network of my choice per the manual instructions.
  3. When viewing programs from the Eyesy web editor, I no longer see any feedback on the bottom third of the screen (error logs, which mode is loaded, restart dialog, etc).

I am putting my original card back in and will wait until further testing of 2.1 is done by others. OS 2.0 is quite functional as is.

2.1 is not displayed during startup. Only when you press the on screen display button. It should appear at the bottom of the on screen display.

You are able to connect in AP mode, but not to your network?

That is strange since nothing here was changed here. One thing to try is refreshing the browser if this is happens (it can happen in OS 2.0 as well).

I started today from a completely cold boot and have this to report:

  • 2.1 marker on the status display screen - yes, now I see it. Would just be nice to see this on start up :slight_smile:

So that’s good, but still some head scratchers…

  • Still unable to connect to my own network using http://192.168.12.1/, despite having set up my network in Settings. Wondering if it is because of the distance to my router. I work on the third floor, but my router is on the second. So it could just be a range issue. AP mode works fine, and that’s what I’ve been using for months. But I would be unable to do certain things in that mode (like the Patchstorage sketch involving camera access).

  • Still seeing no command/error message feedback in the lower part of the Eyesy browser. See image below. That was after start/stopping the video. Also no feedback on what mode is loaded when changing them with the arrow buttons. I rely on that feature a great deal when working with the modes.

Have you tried refreshing your browser? You can also try opening that page in a new private browser window to avoid issues with the browser’s cache…

Yes, as I said, I went back to everything from a cold boot. I’ve also tried from an Incognito session and have the same issue. Console is not providing feedback.

Thank you for the update.
(I didn’t know if your ‘cold boot’ applied only to the EYESY or not)

We’ll take a look at the code and get back to you.

https://techterms.com/definition/cold_boot

Thanks for the definition. Again, hard to say if your first mention of cold boot applied to both EYESY and your computer.