Organelle M screen blank, no sound, led is on

Reached over to play some on my organelle today. It had been sitting for about 2 months. Cut it on and the led popped on like usual, blank screen at startup as usual before boot, then… it just stayed blank. No sound, nothing. Checked the batteries. They were nearly fully charged(panasonic eneloop). Checked with the power supply, same thing. Removed the SD and updated to 4.0, etched perfectly as before with no problems, re-installed into the Organelle, same thing. Could it sitting that long with these batteries still installed hurt the machine? I really have no idea. I hope it can be salvaged, it’s only a year old. If anyone else has had anything similar happen, please let me know what I may be doing wrong, or maybe I just discovered a new way to destroy things… yeeesh…

they get upset if they don’t get played with :slight_smile:

seriously though…
leaving batteries in should not be a problem, unless the batteries fail and start leaking, which could cause corrosive damage - but that would be pretty obvious.

if the led flashed a lot, and then turned off, that indicates something was working…
as you say screen (unlike the organelle-1) the screen stays blank, all the way up until the boot menu appears. it would then remain silent until you select a patch (which I guess was impossible, since you couldn’t see the screen !)

at this point, Id say one of two possible issues.
a) the sdcard had failed, so couldn’t boot properly
b) display had failed, so organelle-m was running ok, but you just couldn’t see anything.

however, replacing/upgrading the OS was not a good idea, it just complicates matters - now its unclear if that really was successful or not.
(as, some have had issues with this, depending on their desktop machines etc)

so now you have to determine if its a hardware or software issue…

here is what I suggest:

you need to connect a tv/monitor and usb keyboard to the organelle, then turn it on.
this will enable you to see if the organelle is ‘booting’ or not.

(have nothing plugged into the USB ports, other than usb keyboard)

if the OrganelleOS is installed correctly and the basic hardware is working, you will see it boot up, and allow you to log in.
if the display is still blank, then it could be the screen, but we will be able to determine this from the logs

IF you the tv/monitor does not show it booting, or does not get to the login prompt, then either the OrganelleOS has not installed properly, or its possible the SD card is faulty.
(there are a bunch of other possibilities, e.g bad psu, but those can be determined IF you are in this state)

have hope though, most likely issues is something to do with the software install, or a faulty sdcard.

HI,

I have the same problem,but generally after a few reboots suddenly the menu appears.

I have this same issue with a brand new Organelle. With power supply it boots up, but with fully charged batteries it stays with a blank screen and the LED flashes between the start up green and blue. But nothing ever happens.

Just an update here. I took the organelle apart cleaned the contacts on the sd card reader, and took the raspberry pi out of its holder and cleaned all of its contacts. Boom! It worked! … for a week or so. It sat again for a week. Went back to it and the same thing. Took apart again. Cleaned it. Worked again. I dunno? I think the fact that it is near a window that is usually open may be causing some minor oxidation that is causing the problem. It currently isn’t working again. So planning on some deoxit again. Perhaps the upcoming winter will let me know if that is the problem.