Organelle OS 3

i am quite often compiling them on the raspi though can you share the .sh so i can use it there.
I looked at the github but i didn’t see it

I already tried a different and reformatted USB Stick with only the update on it.

Also tried Unzipping with The Unarchiever and Stuffit Expander on Mac. Don’t have a Windows-Computer to try it there

Hi there, this update has piqued my interest. Are you able to confirm: am I able to ssh in to the organelle and write patches without a computer? Can you also list some other programs that can be run i.e Csound, SonicPi, C++, Python?

yes, you can ssh into the organelle to write patches (or connect an hdmi monitor and keyboard/mouse to organelle)
out of the box - Pure Data, Python , C++,
after that, theres a SuperCollider install available (and mother host supports this in OS 3) , Csound you can compile and install.
SonicPI… i guess would be possible, as based on SuperCollider, so presumably you’ll need to just build.

ok, lets do this on this thread, for the time being… so I can get a better idea where to go from OS 3.0 onwards…
once Ive got time etc… I’ll create a new thread about what options there are , and where we can go from here.

(its a bit of a painful subject due to the way Pure Data works… frankly its a bit crappy about midi device support)

EDIT: ok, Ive summaries here, what is currently possible, and potentially where to go in the future…

1 Like

did you put it in /usbdrive/Patches … and without changing the directory name…
it needs to end up in : /usbdrive/Patches/UpdateOS-3.0

if you change that it might fail, that said… Im not sure if it even starts.

Im a bit confused though… as Ive tested this on a clean 2.1 organelle, with a usb install of this image from a mac (10.13.2) and it worked fine.
(iirc, i used the built-in uncompress on macOS rather than a 3rd party program)

basically the error messages means one or more of:

  • a files content has changed
  • there are missing files
  • there are extra files

obviously, as its works here, and for others, we know that the zip file itself is fine… as otherwise it would fail for everyone, the question is what is happening when you unzip it.
(id suspect, its extra hidden system files being introduced that is causing the issue, unless your usb stick is ‘damaged’)

If you continue to have issues then I can create a utility that will tell us what the issue is, and then how you can resolve it … but honestly I do not have time to do that for a while…

(a glimmer of hope… is that from OS 3.0 onwards this is a thing of the past, as zip/zop are supported on the organelle, we don’t run into the oddities introduce by macOS creating system files on the usbdrive)

one thing you could do , is after unzipping the file, and transferring to the usb stick, run blueharvest , there is a free 30 day trial… this basically will remove the rubbish macOS puts onto removable drives. its not ideal, and I’ll come up with something better for a future release, but might get up n running today :wink:
(without us resorting to the command line!)

I’m confused, too. I didn’t have any trouble installing the 2.1.Update.

I’ve put the files into /usbdrive/Patches/UpdateOS-3.0
I tried downloading with Firefox and Safari. Unzipping with built-in uncompresser, “The Unarchiever” and “Stuffit Expander”.
I also tried 3 Usb sticks now. I’m running a Mac Pro on 10.10.5 and a Macbook on 10.9.5
I tried deleting hidden files using terminal to make them visible and then deleting them (also emptying the trash) on both Macs but it didnt help.

I attached a screenshot of the folder structure (without the hidden files shown). maybe you find something missing, but it still doesn’t make any sense to me.

ok, you cant just delete all hidden files, as some are needed (.ssh, and .pdsettings for example) and if you delete these, it will also complain the upgrade is corrupt (as it now is :wink: )
… its just the hidden system files that macOS creates.

which is why i suggested blueharvest, as it knows what files these are.

… Im wondering if perhaps 10.10/10.9 is creating a different set of hidden files
(different unzippers wont make any difference imo)

ok, download the update again… so we know you have not deleted anything vital :wink:
then replace with this file (unzip it) (1.2 KB)

then transfer usbstick to organelle and run again.

this will then create a file on your usbdrive called /usbdrive/updatediff.txt, which will tell us what is failing,
(upload this file here, or dropbox so I can see its contents… dont paste it here, as it might be quite large ;))

then I can give you a temp fix, and also resolve more correctly in 3.0.1

this is what it says. I hope it tells you something. thank you for your help already!

I’m going to download blueharvest now.


ok, its the hidden .DS_store file created by macOS

81727338479684b8bfe461e3f9edebf5493a3b41  UpdateOS-3.0/.DS_Store

(the deploypd… is just complaining because of course we have just changed it :wink: )

Im adding a fix now for the next release…

1 Like

Yeah! It finally works! Thank you so much!

So the problem are these stupid .DS_store files. Copying the Update to the Disk and then running blueharvest worked for me.

I can’t wait to see the new features to be used!

Tank you

1 Like

i will have a version of Csound that runs inside of Pd patches ready very soon

1 Like

Quick query- update worked smoothly. Then I copied a zipped super collider dx7 patch to my usb stick, I then could see it listed with instruction to install. That seemed to work fine, even got a message saying enjoy using… things is I can’t find the patch to select it. I noticed there is now a “new folder “ which has no patches in it. Any ideas?

is there a download for that zipped patch?

did you install SC_Install … you still need to install this, if you want to run supercollider patches.
(if you already have done this prior to OS3, then you dont need to do it again)

did my demo SC poly patch work?

also… just like PD, you’ll probably want to modify an SC patch before it will do much on the Organelle.
(e.g. add display elements, and knob control)

That would be my problem, I downloaded but did not install sc :joy: thank you for a speedy reply @oweno and @thetechnobear.

1 Like

how are we drawing to the oled screen?
I have a nice lissajous patch to test

there are a whole load of new osc messages, e.g. gPrintln, gBox… owen has put up a patch on patchstorage which demonstrates them.
btw: don’t expect real time scopes, that’s not going to work… the screen is only redraw at certain rates, plus if your not careful you could create so much osc traffic you’ll start affecting your audio :wink:
(of course, well coded, you can still do a lot of really cool things)

oh ok, how about a graph for ADSRs then A la Omnimod?

1 Like

yeah, they could easily be drawn, at the end of the day, an adsr is 4 lines … so gLine is your friend.

the slightly tricky bit is then integrating this into your chosen parameter menu system, but that’s just juggling code around a bit.
(sorry no tips for that, since ive moved to my own parameter system now, which is all built in C++ not PD :wink: )