Organelle OS 4.0 - WiFi Function Demos

We just put up some demos of the WiFi functions in the Organelle OS 4.0. Hope they’re helpful!

Intro:


2: Clarifying When to Use Existing Networks vs. Create Access Point:


3: Demoing File Management:


4: Creating a Custom Access Point (AP):


5: Remote Viewing & Programming (VNC):

1 Like

Is it possible to sync 2 Organelle wirelessly? If so a video showing how would be cool.

Ableton link, should happen automatically?!

Ok, I didn’t try it yet, presumably wifi just has to be turned on on both Organelle, I don’t want to connect to my router, is that what you are saying @thetechnobear ?

Yes. We used Link to sync more than two Organelles together in these videos. We were outdoors so had to create our own network (AP) with one Organelle. The AP was shared with other Organelles:


All you need to do is:

  1. Turn on Access Point (AP) on one Organelle
  2. Join the AP with the other Organelles.
    a. The other Organelles will need to know the AP name & password so might make sense to get set up before you go outside.
    b. Once you have AP, other instruments (phone apps, Ableton, etc.) can join the Link session too.

Hi there, I’ve updated to 4.0 and everything is working fine. I’ve been able to Start Web Server and Start AP and being able to connect via a web browser to manage Patches. But I couldn’t connect via organelle.local, I’ve had to use the IP 192.168.12.1 in order to make the connection. Thus I’ve tried to connect via VNC Viewer but I can’t use the IP so I’m stuck there. How come? Any clues would be nice. Best. N

VNC should work over IP address as well.
What vnc client are you using, I’d recommend the free one from RealVNC.
Also have you an organelle-1 or organelle-m?
( they are slightly different as use different vnc servers)

What error are you getting when using IP address?

Just to be clear if your using AP, you should use
192.168.12.1:5901

Hi, thanks for getting back to me,

I’m using VNC Viewer 6.2.113 (r42303) from RealVNC on HighSierra 10.13.6.
I have an organelle-1
I’ve tried 192.168.12.1:5901 but VNC Viewer said is an unsecured connection and the login is greyed out and I can only type a password but then when I use “music” it failed.
Here’s a screenshot.

it’s insecure - that’s fine, just say ok :slight_smile:
the password is coolmusic on organelle-1… and yes, its only password, no username

Hi Technobear, it’s working. perfect. Thanks.

Do you have a network named “music” to connect to? The “music” network is the name of the default network that we use for testing the WiFi. You need to first connect in AP mode (to the “Organelle” network from your computer), then you can add the name of your home network.

I’m getting a very poor connection with VNC Viewer when connected to my wifi network. My desktop PC can access the Organelle and allow me to see the linux desktop and access files, but when I load a patch from the organelle, the VNC viewer freezes. Turning VNC mode off and back on within the Organelle doesn’t help.The only way to get it back is to reboot the Organelle. Any suggestions?

Edit: I should also say I’m not very far from my router either. I’m using the Edimax EW-7811Un wifi adapter.

There may be a couple issues here. Which Organelle do you have?

We recommend using USB-WiFi adapters with the RT5370 chipset. I looked but could not find which chipset is in the USB-WiFi adapter you mentioned.

Can you try using the Access Point method to connect your PC directly to Organelle and then use VNC?

I have the version 1 Organelle. My desktop PC doesn’t have wifi (it’s wired up w/ ethernet) so I can’t access the Organelle’s AP from that. I do have an old macbook laying around I could try it with, though I’d prefer to create patches from my desktop PC.

Are there settings within VNC Viewer I could adjust? It seems as though the VNC is timing out on the Organelle for whatever reason. I thought it could be a performance issue as well because I notice on the Organelle it takes quite a lot longer to navigate around the UI. For example, when I go to settings to adjust wifi settings, it’ll be stuck on the “loading” screen for quite a long time. This is while VNC mode is enabled on the Organelle.

Jumping in with a question: I have an Organelle M on 4.0. I’m able to connect to the AP mode & web server, but I cannot connect to my home wifi network. My router has 2.4 & 5ghz. I read that 2.4 is the way to go, but no luck. My wifi network password has spaces in it. Do the spaces need to accounted for somehow when entering the password?

Did you ever find a solution to this? Currently running into the same problem at the moment.

Edit: Organelle is saying its connected to my home WIFI, but it is not showing up on my attached devices list in my router, and I can not ping it from a device that is connected to the WIFI.

Is this because of a security setting in your router?

Are you able to get your computer onto the Organelle’s Access Point?

I don’t have any security settings on my router to reject devices.

I was able to get my computer on the Access Point on OS 4.

On the previous Organelle OS. I was able to connect to my WIFI, and open up the patch manager from any device on the network.

For OS 4, I set it up the same way I had with the prior version. It just never resolves when I attempt to reach organellem.local or my Organelle’s IP. I actually just ended up reverting back to the prior OS, and boom, I could open patch manager, load patches on to the drive, etc.

*For clarity, this is with the Organelle-M (I dont think this would matter, but figured I’d relay that info anyway).

Are you ping-ing from terminal? Which browser are you using?

Yeah, I have a MacBook Pro and a windows 10 desktop. Tried pinging from terminal but no dice. Also using chrome as my browser.