Organelle OS version 4.0

These are things like typos, and, for example, better CPU usage reporting on the Organelle M’s Info screen…little things like that.

Performance wise they are going to be the same. All the patches will continue to work as before, including ones on USB drive.

We decided to go with an SD card disk image as the update path this time, instead of an update patch like last time. There is a bunch of software getting updated / installed that would have made an update patch impractical. A disk image also ensures users are on the same page from a software standpoint, and gives them a way to always revert their device to the ‘factory’ state.


The old card was runnning the old OS – I just got my hands on a 32 gb card that i will try to flash. I did use etcher (unzipped 4.0) instead of DD, and I couldn’t get it to boot. flashing the card should wipe it, correct? If that fails i will plug in hdmi

so i tried again with the 32gb card and it failed, so i tried to connect via hdmi and i couldn’t with 3 cables that work. So then I put the 4gb card my pal had in there with 3.1 on in and that loaded as normal but still getting nothing out of the hdmi. is it possible it is faulty?

Hi, I got same issue, during the first attempt I unzinpped the file with the native MacOS app, then I tried with the app suggested here, The Unarchiver in my case, and now it works
hope it helps

I tried with 2 diff cards, the original 4gb one and a 32gb card. Gets stuck at 99% on startup.

I hooked up a monitor and it says it’s in emergency mode and is asking for a root PW, which I’m not sure I know.

reviewing the msgs prior to this it reports one error VFS: can’t find ext4 filesystem, failed to mount /sdcard.

Quick heads up @oweno there’s Organelle M language in the Organelle 1 updating instructions here:

Firmware is all okay and it looks like a quick copypasta issue.

Thanks for all the hard work all!

@thetechnobear OTC? :grimacing:

Thanks @atomboyd, fixed!

@wolfereeno yes, this looks like an issue with the SD card. Either the burning step did not work correctly, or there is some other problem with the card itself. The 4gb card will not work since it needs to be at least 8gb. I’ve never tried on a 32gb card, but it should work… If you have any other card to try that might help. What computer are you running Mac? Windows?

I’m running etcher on my mac. I could try on a windows machine.

BTW, maybe this is just a linux file system thing I don’t understand, but when I inserted the original organelle 4GB card for the first time, I got a msg saying “the disk you inserted was not readable by this computer.” I got that after I flashed the 32GB card too.

I’m unable to connect via the VNC server included in this update. I’m trying from Mac OS X and have tried a few different VNC clients. Is there a password or alternative port setting that I’ve missed. (Keeps saying connection refused on port 5900 I think)

Organelle 1 or M? Also, port should be 5901 (not 5900)… It should ask for password.

So I reflashed the 32GB card on my windows 10 machine and all worked flawlessly.

Not sure why my Mac didn’t work, maybe it was an antivir running. But I’m up on 4 now just fine.


Organelle M…I’ll try that other port. Did I miss setting up a VNC password somewhere, or is there a default password I need to use?

For the Organelle M, the user and password are both ‘music’.

Same issue for me as mentioned above. Just updated to OS 4.0, and using Mac OS X. Tried to connect with RealVNC and other VNC clients, but nothing works. Tried every combination (organellm.local, organellem.local:5901, IP from the organelle). When using the IP approach, it tries for quite a while then shows the “gave up waiting for the computer to respond” message. Is there any particular config with the web server and wifi connections that is required other than being in AP mode? Thanks for any assistance. (P.S. I’m about to update to the latest Max OS X update just in case that’s part of the conflict)

Hi. Just chiming back in to say that the Mac OS update (on Catalina 10.15.3 now) didn’t solve anything. The hostnames are never recognized by the device, and it just times out on the IP.

So you are able to see and connect to the ‘Organelle’ network from your computer? Are you able to see anything using web browser? (select ‘Start Web Server’ in the WiFi menu and then in your web browser navigate to organelle.local or use the IP given in the Info menu) … this would help to know if it is a network problem or a VNC problem.

Yes, organelle.local is running and functional. I just connected to that using my web browser and copied over some patches to the organelle, so the network on the organelle seems to be running just fine.

If organelle.local works, I assume your on an organelle-1 - correct?

So web server is working In AP mode - correct?

But if you do ‘Start VNC’ on organelle, and then try to connect on
With RealVNC client it doesn’t connect? What’s the error?

Same if you use the IP address?

1 Like

Ah, I mistyped. I’m on the Organelle M; just got mine a month ago. Also, I just got it working!! After further sleuthing, it turns out that my MacBook was quietly shifting back to my home wifi network instead of the organelle network for some reason. To anyone else with mysterious connection issues, make sure your laptop and the organelle are definitely on the same network or they will not become friends.

Thanks for checking in to assist @thetechnobear and @oweno . Back to exploring for me.

1 Like

Hey there, okay, I’ve bought a new MicroSD SanDisk 32GB Extreme to install the new 4.0 os and keep my current 3.1 os on the original 8GB MicroSD. Everything is running fine but I can’t mount the MicroSD card on my mac desktop in order to copy all my patches on the MicroSD to free up an USB port on my organelle. Any idea why? Many thanks.