Organelle OS version 4.0

Gparted worked like a charm on my xubuntu! Should have thought about it right away :slight_smile:

Does that mean I can run the full Supercollider IDE via VNC on the Organelle? I can’t find a way of opening a supercollider file other than as a plain text.

running the SC IDE on the Organelle is not necessary…
you can run the full supercollider IDE on your pc/mac - and then connect to the supercollider server running on the Organelle.
(the default patch allows remote SC connections)

this is much more efficient, and a nice experience that trying to use the IDE over VNC :slight_smile:

status: do you have an organelle-1 or organelle-m?
the organelle-1 is working fine.

unfortunately, as stated elsewhere the organelle-m has the default SC package installed which does not work unless your running X, which is obviously not normally the case - so it needs to be recompiled to run headless.
also jackd also needs to be installed on the organelle-m.
if you want more details on this, then check the other thread where I wrote this up.
(its quite easy to resolve if your familiar with Linux, otherwise when I get time I’ll put up a ‘patch’ to fix it)


Hey Thanks,
I’m having the Organelle-1. This sounds like a very convenient way of developing SC patches.
I’ll give it a try tonight :slight_smile:

i am likely to do the same !! 9Apps VidMate

Hello, it’s been a while since I touched my Organelle so I was very pleased to hear there was an upgrade.

I’ve followed the instructions in the manual inc. flashing an 8gB SDcard - however Balena tells me the disk image is too large at 7.95gB at its Unarchived size and extra 205mB is required. Can anyone help me with this - I’m currently trying to flash from the .zip even though instructions say this won’t work!

Hmm, that is annoying. Not all 8 GB cards are actually the same size… We based the image on the 8GB card that ships with the Organelle, did you purchase a different one? also, did you try unzipping first as the instructions say?

Thanks for swift reply!

the original SDcard that came with my Organelle was only 4GB so I dug out an old 8GB - it may be as you say that it’s not quite big enough it says capacity is 7.74GB which I didn’t think was particularly out of range.
am I to understand that patches are now stored on the SDcard along with the OS? If so I’ll bump the size up to 16GB.
I’m also downloading the .zip again as it may be corrupted I have a feeling Mac was acting a little strange this afternoon!
I’ll report back if I’m still stuck.

okay - update all sorted. got me a 16GB card today and install went like a dream.

1 Like

Is there/could be any way of updating the Os without flashing the Sd? I saw some older Os updates on Patchstorage

not the really.
OS 4.0 uses the sdcard for patch storage which means the sdcard needs to be on a larger sdcard and then partitioned.
( this was not the case on prior releases)

Theoretically you could build motherOS from GitHub and continue to use the usb stick. But really the better WiFi / sdcard support is the key benefit of 4.0.

Finally, if you look back at forum posts , you’ll see that a lot of people has small issue with the ‘upgrades’ as they never quite end up with the ‘same image’ , and many ended up flashing the sdcard to resolve these issues.

Anyway just my opinion…

1 Like

So with a 16GB Card how much storage does that afford you?

I can’t seem to find the update anywhere. Did it get removed?

The updates are still available here:

Since the update, I’ve had patches not respond to the four knobs. The solution is to twist the knob all the way clockwise or counter clockwise. Once it hits the end, it should affect the parameters.

It’s an easy enough solution but never use to be a problem. How can this be fixed this permanently?

@prockidile I had that issue with the previous version

@prockidile & @jonbuzzard

If you are using multipage patches from C&G, the knobs have a ‘takeover’ requirement. You have move the knob to match the value set the last time you were on that page. This prevents values from jumping to undesired settings when you choose a new page. Once you match that previous value, the knob will respond normally.

I assumed it was something like that but I was just letting @prockidile know that that was not something exclusive to the update.

heads up, the original organelle’s manual has the wrong link in the section for setting up wifi. it says to navigate to organellem.local/ when it should be organelle.local/ sorry if this is the wrong thread but i couldn’t find one more appropriate. thanks for making such cool products!

1 Like

thanks @alexm - fixed it!

1 Like