Organelle + Sonic Pi

Hi, I’m a proud new Organelle owner - a present, received yesterday, I’ve been thinking about one for ages :smile: What a fab thing it is.

I thought I’d share one of the first things I wanted to do - integrate it with my main setup which uses Sonic Pi to provide clock, some sounds and put out midi.

The simple thing is to just send it midi, and play it like any other voice. That’s bread and butter, but I’m keen to use it a live-playing device. Of course I can just play it live, but the next thing is to record phrases and have them looping in sync with the track.

I tried sending midi clock to the Organelle and while that works fine, the quater-note-quantising feature of seq3 seemed to always shift the phrase about by a step (or half-step, not sure). Anyway, not what I want.

The problem with having seq3 free-running is that, however good my time, inevitably the loop is going to drift out of sync. So I tried the feature of sending it a midi start message every few bars. That kicks the phrase off again, in time. Very nice!

The slight compromise is that you have to have a note on the downbeat - as that’s what starts seq3 recording when it’s armed. But that’s OK.

For me that’s a nice mode of in-the-moment playing + locking in time, with a bit of organic variability. While the phrase is looping, I can be busy twiddling the knobs to change the sound. Or sipping tea.

This is just a first pass, so I may find other ways. Anyone else got any experience or tips - pleased to hear them!

My ideal would be that in seq3 you could set a tempo and duration in exact beats. I’ve already written such a patch in puredata so when I get stuck into putting my own stuff on the Organelle I may have a look at that.

The newest version of the patches have a newer version of seq3 that should fix these MIDI clock input problems. You can download the whole set:


Thank you. In fact I seemed to have solved this one by not using a midi-usb cable. Also the ‘midi start’ technique seems useful for some other patches that have a sequencer but not Seq3.