Serialosc/monome with Organelle?


#121

I have in no way been distracted from what i was meant to be doing to today. In particular I haven’t spent any time making an APC version of this work. no. no.

Here is the patch - it feels silly not using the rest of the controls on the APC so I’ll revisit this. I’ll also likely make it into an orac module as well. Not today (really not today). I took a slightly different approach to ghostly606 with the osc translation - also irritatingly the co-ordinates of the APC work differently so had to translate those a bit too.

stop and start are the top right buttons on the APC (not shown in the video since I’d not implemented them when I took that)

https://patchstorage.com/gridstudies-apc/

EDIT - ugh the timeline is still going backwards - I thought I’d fixed that - also odd I didn’t notice! - will fix later


#122

Just had a look, go on… you can say it… you took a cleverer approach! :wink: I’m new to Pd so I used brute force! Really thanks for sharing this though, I’ll take a look and sharpen my skills! :smiley:


#123

well not so clever since I’ve just noticed it is still going backwards :wink:

I’ve been writing software for nearly 40 years (so much so it is no longer what I do for a living - I’ve come out the other side!) and I’m also very lazy so will tend to go for the easiest way to my mind

Looking at other peoples code is definitely a good way to learn

BUT thank you in the first place - since I’d not have even thought of doing this without your work. Also - your video was the first time I’d got what it was meant to be doing so all good


#124

Fixed the backwards timeline thing - forgot to save after I fixed it the first time! d’oh

https://patchstorage.com/gridstudies-apc/

I also took the space out of the name so if you install it it will make another copy - sorry about that


#125

Thanks for this! You just brought my APCmini back to life :wink:
It was reserved to be used with the OG, so…


#126

I’m thinking that the sliders at the bottom need to be controlling synth params (I’m not particularly wedded to the original minimalism of monome in this case)

However I’m down a ridiculous rabbit hole of distraction right now -starting with watching a documentary about Don Buchla, on to my Roli light block and beyond - so might be a week or so before I come back to this - having started about 5 separate things trying to get them all closed off.


#127

hmm reading the monome site about grid apps - lots of interesting ideas!

I think I need to get my GitHub repo up and turn this into a patch people can include

ideas, ideas…

definitely want to make some Orac modules for this - lots of possibilities


#128

Swinging by to say that I grabbed a Monome Sixty Four (I think from 2010ish?) off eBay after seeing this thread.

Initially setup didn’t work, but after updating to 3.1, it worked fine.

Also heads up that the same issue with the 64 as 128 in that the Organelle can’t seem to deliver enough current to power all LEDs, so currently running through a powered Elektron Overhub and it’s fine.

Thanks all for your contributions, this is cool.

Tom


#129

If I want to start making stuff with my grid and organelle, am I right to assume that it would be much easier to assume that I’ve got wifi working so I can go through these steps ?
Thanks, and sorry again for being such a noob, Linux can be frightening at first, and not being a native English speaker, the whole process is confusing.


#130

You don’t need to go through the steps on monome’s site, to install serialosc/monome on Organelle. Wifi is not necessary.

Download @quilime’s serialosc installer here: https://patchstorage.com/monome-grid-apps-serialosc-installer/
Put the Serialosc-installer patch in your Patches folder, and run it like you would any other patch. This installs everything you need. When the installer is finished, plug in your grid and it should light up.

Then you can go straight to the grid studies for pure data: https://monome.org/docs/grid-studies/pd/ . Or you can use the pd ports of Aleph grid apps, which are included in the same download as the serialosc installer.


#131

Wow. Thank you so much !


#132

Allright.
This is wonderful.
I’ve got one problem, though : I’m using a 256 grid.
While all the buttons are registered, only the top half of the leds are working. I suspect that the [grid] object doesn’t handle rows 8-15 for the leds. Am I right ?
Who is the (wonderful) person responsable of coding the [grid] object ?


#133

hi @chapelierfou, you can find more info about the grid object in this thread - Aleph's grid apps

you can also use the serialosc subpatch no need to use the grid object :slight_smile: also, the grid object does not allow monome col, row or map massages.


#134

I believe the 256 is fine (I’m on a sixty four but I’m pretty sure others are using 256.

The Organelle can’t deliver enough current over USB to power all of the LEDs, so someone on here advised that a powered USB hub should be used between Organelle and Monome. See if that fixes your problem.


#135

Thanks. I’m using a powered usb hub.
Using just the serialosc works just fine with the bottom half of the 256, so I really believe this is a bug with the grid object. This is really fine for me. I don’t even understand what is the point of the grid object, to be honest.


#136

Can anyone help with instructions on how to uninstall serial osc from my organelle or how to do a complete reset of my organelle so I can re-install serial osc. Reason being that I have not been able to get any of the monome patches to work except for the poly patch. I just added meadow physics to orac last night and for some reason it only clocks the first note. Everything else is unresponsive. Hoping that possibly by starting over it may rectify the issues I’ve been having.

Btw I’m running it all off of the micro sd on OS 3.1


#137

Here are instructions for loading a fresh OS onto the microSD card:


#138

Right on so it’s the same process I initially used the first time. It’s just a matter of using a fresh card or erasing my card and then flashing the image back onto it. Thanks


#139

I’ve been travelling so haven’t had a chance to respond before now

ok - you’ve reinstalled and that didn’t change it. If the poly thing is working that would suggest your grid/serialosc is ok. You’ve done a reinstall so I’m guessing you are basically on a standard setup with orac added?

So - meadowphysics - the clock comes from the orac clock - which clock are you using in orac? are other modules that use that clock working?

Do you know how meadowphysics v1 works? only the top row clocks when you first load it? it’s very different from ansible meadowphysics (which I also plan to port)

https://monome.org/docs/modular/meadowphysics/v1/

you have to tell the top row to clock subsequent rows?

let me know if any of those things help - if not a quick video of the grid misbehaving might be useful


#140

Oh damn this could definitely be whats going on here. I feel like an idiot now haha. I was definitely expecting it to work like ansible. I’m going to try it again tonight after work and guessing it will probably work considering I’ll be using the proper rules. Thanks for the reply by the way!

Update: that was totally the problem. I have two instances of it running without any issues now. The only problem that I did run across was that if I tried Orac first then the grid was unresponsive. If I loaded the poly patch first and then opened Orac the grid worked fine. Other than that it’s pretty damn cool to be able to do more than one sequence at a time with one grid