Organelle OS Update, Example Patches

What patches specifically are giving you trouble?

Spectral Delay Delux the RE Space Echo. Any quick fixes possible?

If my understanding is correct, all parameter values for each fx and whatnot are saved only if the patch was crafted with the new multi-page menu. Most patches still offer the old menu and it looks like only those settings are saved which are on the display at the moment you’re saving the patch. Is this correct or am I getting it all wrong?

1 Like

Yeah, only the first 4 knob values are saved. If a patch uses multiple pages of knob values, that patch will have to be updated to save use Save and Save New.

Dang. The ability to save parameters on old patches would be mighty useful… Could a future master OS update fix that, or is it just not possible?

they’d have to be coded in the style of the new patches…the readval/saveval stuff is essential. The old patches could be retro-fitted but the way the paging/knob stuff works makes it necessary to re-code i think

Sorry to be late on this ! I’m the author of the RE-tape echo patch. It has been made at a time where the Organelle had no state-saving capability, so i had to make it my own way.
As i’m not very fond of the actual Organelle state-saving method, i won’t upgrade my patch to use it.
This being said : RE-tape echo loads the preset 0 on load. So there’s an easy workaround :

  • Download the most recent version of RE-Tape Echo (critical) : https://patchstorage.com/re-tape-echo/
  • Enjoy it :slight_smile:
  • Save your preset in any of the 10 slots
  • Use Organelle’s “save new”
  • Then load your newly created version of RE-Tape Echo (should be named RE-Tape-Echo 2 or something), load the aforementioned preset and save it in slot 0.
  • Next time you load the patch, it should init with your preset.
1 Like

Sweet, that’s a great work around. So simple I should have thought of it
myself!

Top patch by the way - I use it a lot :clap:

1 Like

Most of you are probably very familiar with the OS update, but here’s a video explaining three of the new features in OS 2.1:


(apologies for the scrolling brighter line of text on the screen, it is not there in real life, but only in this video due to differences in the camera’s shutter speed and Organelle screen’s refresh rate).

5 Likes

hi, how long does it usually take to update? my unit’s taking days, i’ve tried swapping out the usb and redownloading the patch, it’s still not finishing. thoughts?

It should only take a few seconds. You might want to download a fresh version and try again, and maybe try a different USB drive if possible. There could be problems with the update files.

http://thepeacetreaty.org/organelle/patches/Update-OS-v2.1.zip

okay I gave that a try and it’s still not finishing, not too sure where to go from here.

Please try flashing the entire OS to your microSD card. Here are instructions:

I’m also having trouble installing this update. I’ve loaded and reloaded the patches a million times, and I’ve not changed the folder title so everything should be working properly. When I hit the aux button to install, the “updating…” screen just sits there for eternity. Any help would be much appreciated <3

did you try downloading the update patch again? or using a new or reformatted USB drive? it might have been corrupted when it was downloaded or copied to the drive.

I have tried re-downloading and using a different USB. I don’t have a new USB drive in the house, but is that really the issue here?

99% of the time so far it’s been the USB from what i have seen

YMMV but it’s worth the try

Hi, i’m new with organelle and i want to update OS v2.1 but i don’t know how. first, i’ve downloaded and unzip it. in the folder “update-OS-v2.1” i have two more folders ( “filecheck” and “root”) and othersfile. what is the next step? should i copy folder “update-OS-v2.1” in “Patches” folder SDcard? Thanks.

Info here @maxipuchar :

To update simply download and run the patch.
(Put “update-OS-v2.1” dir ON the USB stick inside PATCHES dir, then on the Organelle select that patch )

You will be prompted to press Aux button to start update. The Organelle shuts down after the update and you will have re-apply power.

Select Info in the System menu and it should say version 2.1

Hope this helps

readyy mann!.. thank you very much for you help.