Organelle OS 3.1 TB Beta

So i’m currently running mac osx 10.11.6. Went to a friend yesterday and used his computer and
usb-drive to put the update on, transferred it to the Organelle and it worked! I then transferred the my patches (backup from hard drive) back to the previous usb-drive that i got with the organelle. I figured with the update the files couldn’t be corrupted. But when i turn on the organelle there seems to be a problem with the patches considering 70% of them are currently not working. Since the 2.1 update i had some difficulties with some patches but not as much as now. I use a lot of copies of the sampler rec patch where i’ve recorded many samples on to but a lot of the samples seem to be distorted or even missing and some i can’t change the speed. A lot of patches just go to a black screen with only the I:…. and O:…… (input and output showing), some have no sound and some patches have an arrow now showing it’s a map but when entered the patch says ‘no patches found’. There are also codes between the patches.
Specifically: QAMP’’240 SAHP’’:17 SAMPLE’’3 SAMP’’!?w SAMT>223
Thanks for helping me out with this i really appreciate it.

sounds like the USB drive has had it.
the original one supplied with the Organelle seems to have limited shelf life.
one ive got also pretty much gave up the ghost.

get yourself a decent brand (SanDisk or similar) and you wont look back, mines not had any issues - and copying too it from the mac/pc is also much faster.
my is similar to the one C&G now ship

Ok, i’m going to the store in a couple of hours i’ll check it out. Thanks

Went to the store and got the usb, transferred the files but the problems i seem to have with the patches are still the same. Should i delete them and download them again to start from scratch?

odd… yeah, what i would do is… delete all patches off the new usbstick, then download one patch, and install that, check its working. then do the rest from the C&G site (new versions all have LINK support :slight_smile: )

i guess if you have been copying the other patches around, then perhaps they were corrupted when you copied off the previous usb stick to your hard drive… all a bit odd though, never heard or seen this before.

Ok beta 3 is here , with some new goodies :wink:

Improved MIDI

With 3.0 we introduced specifying midi devices with alsa device numbers… so your keyboard might be 28:0.
this is ok, but has an issue if you start plugging in multiple controllers, as the order you plug them in, will determine their device numbers
In Beta 3 this changes… now devices are ‘named’, so regardless of order plugged in, or if they are plugged into a usb port, they will still be connected.
so you will now see the config file contains lines like:

aconnect "Ableton Push 2:0" "Pure Data:0"

(rather than aconnect 28:0 128:0)
note: the old format is still compatible.

oh, Ive also removed the annoying ‘press encoder’ after saving a midi setup :wink:

Pedal support

There is a new configuration option for pedal support
Settings->Pedal setup

(tip: this creates a ‘config file’ called, and can be overriden in same way as other files like midi config/mother.pd)

Expression pedals - Expr Min, Expr Max

these specify the range of your expression pedal (min and max)

an example… you plug in your pedal, you find its not quite reaching maximum or minimum on a patch…
if you start PD, you’ll find it never quite goes to 0.0 or 1.0… how to fix, well simply turn up Min until you get 0, and turn down max, until you get 1.0

if you want to be precise a simple pure data patch can tell you the values., simply [r expRaw] -> [print]

this will now print the ‘raw’ values of you pedal , so put it fully up… (mine read 10), now press it fully down (mine rad 830) , set the ExprMin , Expr Max to these values (10, and 830 respectively)

you can also use these value to just reduce travel of the pedal if you wish.

added bonus, if you reverse Min/Max, (e.g. make MIN=1023,MAX=0) , it reverses the ‘polarity’ of the pedal :slight_smile:

Footswitch - Switch Mode

Current Modes:
Patch - is the current behaviour, when the footswitch is pressed, its passed to the patch to interpret
Favourites - when the footswitch is pressed (well actually released), it will switch to the next ‘favourite patch’

This was asked for before, so i implemented
if this is popular Ive a few other ideas in mind ,for other modes:
Sustain, OctaveUp, OctaveDown, Aux, and Freeze.

the idea behind these is is to give some ‘standard behaviour’ to the footswitch rather than leave it up to the patch, which often dont do anything useful (in my experience)

( a patch can select a mode e.g. to put it back in patch mode, send the message /pedal/switchMode 0)


I reinstalled all of the patches and was able to save some of my samples. Everything seems to work fine now! Thanks for all the help :pray:

1 Like

Small bug… or actually a typo: when I go to pedal settings page, the menu displays pedal min instead of max… after changing the max value, it displays correctly as max.

1 Like

I tried it but then i couldn’t get the midi to work so i immediately went back to OS 3.0 and that works fine with the alsa.config file:

channel 1;
usealsa 1;
alsaconfig 28:1 128:0 128:1 28:1;

so it’s a configuration issue. should i remove the alsa.config file when using OS 3.1? is that the problem? what should the midi setup be for a Korg Monologue which i know shows up as two devices? (the organelle recognises it in the setup, i guess it just needs configuring correctly?)

1 Like

how you do this has changed for 3.1, see my “how to” video

But generally for 3.1 if it’s just one device you should be able to just to select it in midi setup

1 Like

ah! thanks! i got it. just a channel issue. i needed to set it to channel 1.

1 Like

it’s nice now because the organelle doesn’t show those annoying invisible files that my mac adds to the Usb stick.

1 Like

This, and this chap:

Have inspired me to get an expression pedal and a guitar. Both are now under my ownership and looking forward to some ambient jams on the Organelle. :smiley:


Hey Mark, I am running 3.1b2 and don’t see ‘Pedal Setup’ under Settings. Am I on an older version? Please let me kow if there’s any more info I can provide. Thanks as always for your tireless work!

1 Like

beta3 (3.1b3) has the pedal options , so yeah you need to update :slight_smile:

Ah, I see. Thanks, got it!

Hi there!

New user here, just got it today. I started at 1.1, went to 2, 3, and now 3.1b3. All upgrades seemed to work just fine on OSX 10.12.6. I just copied files to my USB drive for the upgrades. So far so good.


Welcome! :grinning:

1 Like

I’m on latest OS 3.1 b3 and finally just using the SD card, BUT have strange behaviour about, as soon as I try to configure such a file inside a patch it does not seem respond to it? MIDI OUT is blocked?
Is it only me? or I’m missing something? @thetechnobear @ghostly606

I’m afraid when it comes to anything code or Linux related I am a complete and utter noob, sorry!